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Preface About This Guide

This guide describes basic features of the operating-system environment
for the Apple Workgroup Server 95. The operating system that the server
uses is A/UX, Apple’s version of the UNIX® operating system. A/UX offers
excellent performance and lets you take advantage of both Macintosh and
UNIX capabilities.

What you need to know

Basic Skills is intended for users who are unfamiliar with the Finder
application program and the desktop environment. You do not need to be
familiar with A/UX to use this guide.

This manual presents the skills you need for using the Finder in the A/UX
environment. Many of the chapters contain tutorials to help you learn
essential techniques and concepts. More advanced information on using
A/UX Version 3.0.1 to administer the Apple Workgroup Server 95 is
provided in Server Administration With A/UX 3.0.1.

What this guide contains

Basic Skills contains the following chapters:
n Chapter 1, “Working on the Desktop,” teaches you how to turn on your

computer and how to perform basic operations.
n Chapter 2, “Getting Started With A/UX 3.0.1,” teaches you how to start

up A/UX, log in to an account, change your password, log out, and shut
down A/UX.



n Chapter 3, “Using Files and Folders,” teaches you how to maneuver
within the A/UX file hierarchy and work with files and folders.

n Chapter 4, “Backing Up Your Work With Disks or Tape Cassettes,”
teaches you how to transfer files and folders to and from floppy disks
and tape cassettes.

n Chapter 5, “Working With TextEditor,” introduces you to the
Macintosh-style text editor that comes with A/UX, which allows you to
create and edit text-only files by using the Macintosh menus and a
mouse.

n Chapter 6, “Printing From the Desktop,” describes the different kinds
of printer connections you can use and the various ways of sending a
file to the printer while you are using A/UX.

n Chapter 7, “Customizing the Finder Environment,” describes several
adjustments you can make to your work environment, based on your
personal preferences.

n The appendix, “Menu Reference,” describes the items in the Finder and
TextEditor menus.

The glossary contains definitions of all A/UX terms introduced in this
guide.

Conventions used in this guide

Although A/UX links the UNIX and Macintosh environments, the two
environments use different terminology. For example, Macintosh users are
familiar with the word folder. This term represents essentially the same
thing that UNIX users call a directory. The term folder is particularly
meaningful when you are using the Macintosh desktop or Finder, because
you see items that look like folders. In the UNIX environment, however, the
term directory is more useful.

For that reason, this guide uses Macintosh terminology when describing
how to work with the desktop, and UNIX terminology when describing
UNIX operations.
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The Courier font

Throughout the Apple Workgroup Server 95 manuals, words that appear
on the screen or that you must type exactly as shown are in the Courier
font. For example, suppose you see this instruction:
Type date on the command line and press RETURN.

The word date is in the Courier font to indicate that you must type it.

Suppose you then read this explanation:
After you press RETURN, information such as this appears on the screen:
Tues Oct 17 17:04:00 PDT 1989

In this case, Courier is used to represent the text that appears on the screen.

The Courier font is used for the names of commands, domains, files, and
directories. It is also used for the names of application programs that
present an interface similar to that presented by the UNIX operating system
(a character-based interface), such as the login program. (The names of
application programs that present a Macintosh-style interface, such as the
Finder, A/UX Startup, and Login programs, appear in the regular text font.)

Italics

When shown in text, commands often contain “placeholder” words or
characters that appear in italics. These placeholders represent parts of a
command for which you substitute different values when you actually enter
the command, depending on what you want to do with the command. For
example, in the sample command
cat file

the word file is a placeholder for the name of a file you want to display. If
you wanted to display the contents of a file named Elvis, you would issue
the cat command, typing the word Elvis in place of file. In other words,
you would enter
cat Elvis
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Sometimes italic placeholders are used in other contexts—for example, to
represent text that appears on the screen or to represent the value of a field
in a file. Here is a sample prompt that might appear on your screen:
Apple Computer, Inc. (hostname)
login:

In this prompt, the word hostname is a placeholder for the name of the host
computer to which you can log in.

On-line help and documentation

You can display information about features of the desktop and get on-
screen help in several ways.

Balloon Help

The Apple Workgroup Server 95 software comes with a feature called
Balloon Help, which provides immediate on-screen help when you need it.
If at any time you don’t understand the instructions in this guide—or if
you see a window, button, menu, command, or icon that you want to know
more about—use Balloon Help to get the help you need. For instructions
on using Balloon Help, see Chapter 1, “Working on the Desktop.”

On-line documentation

The contents of this guide, and of most of the other documentation that
comes with the Apple Workgroup Server 95, are provided in electronic
form so that you can display them on your screen. If you prefer using on-
line forms of documentation, you can use the on-line utility called Apple
DocViewer, which comes with the  Apple Workgroup Server 95. The user’s
guide for Apple DocViewer is itself provided in on-line form, in the
Documentation folder on your server. The Apple DocViewer Quick
Reference Card, packaged with the Apple Workgroup Server 95, explains
how to start Apple DocViewer and display the user’s guide.
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For more information

For information about how to set up your system and run A/UX for the
first time, see Setting Up and Managing Your Server, which explains how
to set up your server, peripheral devices, and software, and discusses
strategies for administering your server.

For information about using A/UX 3.0.1 to perform advanced
administration procedures, see Server Administration With A/UX 3.0.1:
Advanced Concepts and Procedures.

For detailed information on A/UX, see the A/UX 3.0 documentation suite.
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1 Working on the Desktop

This chapter introduces the workspace, called the desktop, that appears on
your computer screen. Before you read this chapter, you should have set up
your server according to the instructions in Setting Up and Managing Your
Server. This chapter covers the following topics:
n turning the computer on and off
n understanding the desktop and the Finder
n using the mouse
n using icons, windows, and menus
n performing simple desktop functions, such as opening programs and

copying files

If you are already familiar with the fundamentals of the Macintosh
environment, proceed to Chapter 2, “Getting Started With A/UX 3.0.1.”
Chapter 2 discusses desktop features and activities that relate to the A/UX
operating system.



The Apple Workgroup Server 95 environment

The Apple Workgroup Server 95 operating system, A/UX 3.0.1, combines two
computing environments: the UNIX® operating system and the Macintosh
operating system. A/UX differs from other versions of UNIX because it offers
the flexibility and ease of use of the Macintosh user interface. Because A/UX
lets you use the Macintosh desktop features, you do not need to be familiar
with the UNIX environment to use the capabilities of the Apple Workgroup
Server 95.

The desktop is displayed by an application called the Finder. The Finder
behaves in a slightly different manner in the A/UX environment than it does in
the Macintosh environment. Because the Apple Workgroup Server 95 uses the
A/UX operating system, this guide describes the use and behavior of the
Finder specifically in the A/UX environment.

Turning the computer on and off

Before you start up the computer, you should set up your hardware according
to the instructions in Setting Up and Managing Your Server.

To turn on the computer:

n Press the POWER ON key.

The POWER ON key is the key marked with a small triangle. It is at the top of
the keyboard, either near the center or in the upper-right corner.

 

Apple ADB Keyboard Apple ADB Extended Keyboard
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The computer starts up and displays a dialog box that shows you the status of
the startup procedure. More detailed information about the startup process is
contained in the next chapter. When the startup process is finished, the desktop
appears.

To turn off your computer, you use the mouse to choose a command from a
menu. If you need to learn these skills, read the rest of this chapter and then
come back to this section to turn off your computer.

To turn off the computer:

1 Point to the Special menu name in the menu bar.

2 Press and hold down the mouse button.

3 Drag through the items in the menu until the Shut Down item is highlighted, and then
release the mouse button.

The computer and the monitor turn off.

IMPORTANT  If you have Small Computer System Interface (SCSI) devices,
such as hard disks, connected to your computer, turn them off after you turn
off the computer.

The Finder and the desktop

When you start up your system, the desktop appears. The desktop is displayed
by the Finder program. This program is always open, although it need not
always be the active program (that is, the program currently being used).

The desktop screen is a field of gray (or another color) with a menu bar across
the top, an icon (small picture) near the upper-right corner representing the
startup disk, and a Trash icon near the lower-right corner. The menu bar
contains the names of menus, which are lists of actions that you can perform.
You display, or “pull down,” a menu by pointing to its name and clicking.
(The rest of this chapter explains more fully how to use elements on the
desktop.) You might also see windows open in the gray area. (Windows are
described later in this chapter.)
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The desktop is your workspace on the computer, providing you with a simple
way of thinking about using your computer:
n Icons represent containers of information. Disks, programs, files, and so

forth are all shown as icons.
n Windows let you view the information in the containers. When you open an

icon, a window appears.
n Menus provide lists of actions you can perform on selected icons, windows,

or window contents.

The following figure shows a sample desktop with icons, windows, and a
menu pulled down.

Chapter 3, “Using Files and Folders,” explains in more detail how to use these
features of the desktop.

Using the mouse

You use the mouse to control the movements of a pointer on the screen.
Usually, the pointer looks like an arrow. Much of the work you do on the
desktop involves four mouse actions: pointing, clicking, pressing, and
dragging.
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You point to an object on the screen by moving the mouse so that the pointer
is positioned on that object. When the pointer is an arrow, the tip of the arrow
must be exactly on the object.

You click an object on the screen by pressing and quickly releasing the mouse
button while the pointer is on that object. When you click an icon, it becomes
“highlighted,”  which means that it is selected. A selected icon is the object of
whatever action you choose next.

You press by holding down the mouse button without moving the mouse.
Don’t bear down on the mouse itself. Pressing the mouse button while the
pointer is positioned on a menu name or menu icon “pulls down” the menu.

You drag an object on the screen by pointing to that object and holding down
the mouse button while you move the mouse. When you drag an icon, an
outline of the icon follows the pointer on the screen. When you release the
mouse button, the icon itself moves.

 

Point Click Press Drag

A very useful mouse operation is double-clicking. Double-clicking is a
common shortcut for opening an icon. To double-click, point to an object and
click twice in rapid succession without moving the mouse.

To use the mouse to select more than one item at a time, use a SHIFT-click.
Hold down the SHIFT key while clicking an item, and continue to hold the
SHIFT key down while clicking other items.
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Working with icons

The desktop relies on pictorial representations (icons) to show files, disks,
menus, options, or other features. Much of the work you perform on the
desktop involves icons. Opening an icon allows you to view its contents in a
window, unless the icon represents an application program. When you open a
program icon, a blank window opens, ready for use.

To open an icon:

1 Click the icon once to select it.

The icon becomes highlighted to show that it is selected.

2 Point to the File menu name in the menu bar.

3 Press the mouse button to “pull down” the File menu.

4 Drag the arrow pointer to the Open item.(the second item in the File menu) so that it is
highlighted, and then release the mouse button.

When you choose the Open item, the selected icon opens into a window.
The icon itself becomes filled in with a pattern of dots, indicating that it has
been opened.

A faster way to open an icon is by double-clicking it. To double-click an icon,
position the pointer on the icon and click twice in rapid succession.

When you open an icon representing a file created by an application program,
you open both the file and the program.
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Working with windows

Information on the desktop is displayed in windows. Every window has
several features that help you view the window’s contents. You can
n make the window bigger or smaller
n move hidden contents into view

You can have several windows open on the screen, but only one window at a
time can be the active window. Before you work with the contents of a
window, you need to make that window the active window. The active
window is the one with solid lines across the top (the title bar), on either side
of its title. When windows overlap, the active window is the one that’s in
front. Click anywhere in a window to make it the active window.

Title bar

Active window
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Making a window larger or smaller

You can change a window’s size by dragging its size box or by clicking its
zoom box.

Zoom box

Size box

To change a window’s size with the size box:

1 Point to the size box in the lower-right corner of the active window. (If you don’t have a
window open, select the hard disk icon and choose the Open item from the File menu.)

2 Drag the size box in any direction, and then release the mouse button.

An outline indicates the window’s new size as you drag. You can drag in any
direction to make the window larger or smaller, wider or narrower.

To change a window’s size with the zoom box:

1 Click the zoom box near the right end of the title bar.

The window “zooms” to a size that shows all of its contents.

2 Click the zoom box again.

The window zooms back to its previous size.
Clicking the zoom box is a quick way to view as much of a window’s contents
as your screen size allows.
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Moving hidden contents of a window into view

Without changing the size of the window, you can view any contents that are
currently out of sight by using the window’s scroll bars and scroll arrows.

Right arrowHorizontal scroll barLeft arrow

Down arrow

Vertical scroll bar

Up arrow
Scroll box

To view the contents by manipulating the scroll bars:

1 Open the System Folder alias icon on your hard disk.

2 Point to the size box in the lower-right corner of the System Folder window.

3 Drag the size box diagonally to make the window smaller (about half its current size),
then release the mouse button.

The bars across the bottom (the horizontal scroll bar) and along the right edge
(the vertical scroll bar) of the System Folder window should now be gray,
indicating that the window has contents that you cannot see at its current size.

4 Press the right scroll arrow at the right end of the horizontal scroll bar.

The contents of the window scroll past, bringing into view the icons that had
been out of sight and to the right.
A small white box, called the scroll box, moves to the right across the scroll
bar, showing what part of the window’s contents you’re looking at.

5 Press the left scroll arrow at the left end of the horizontal scroll bar.

The contents of the window scroll past, bringing back into view the icons that
had been out of sight and to the left. The scroll box moves to the left across the
bar, showing what part of the window’s contents you’re looking at.
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6 Drag the scroll box toward the middle of the horizontal scroll bar, and then release the
mouse button.

Now the icons near the middle of the window should be visible.

7 Press the down scroll arrow at the bottom of the vertical scroll bar.

The contents of the window scroll past, bringing into view the icons that had
been out of sight and toward the bottom. The scroll box moves down along the
bar.

8 Press the up scroll arrow at the top of the vertical scroll bar.

The contents of the window scroll past, bringing into view the icons that had
been out of sight and toward the top. The scroll box moves up along the bar.

9 Drag the scroll box toward the middle of the vertical scroll bar, and then release the
mouse button.

Now the icons near the middle of the window should be visible.

Changing the size of a window or moving the contents of a window does not
change its contents. The contents remain the same; only what you see of the
contents changes.

Closing a window

When you no longer need to see the contents of a window, you can close it by
clicking the close box.

Close box
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To close a window:

1 Point to the close box near the left end of the title bar of the active window.

2 Click the close box.

The window closes, and its icon is no longer filled in with a pattern of dots.

You can also close a window by choosing the Close Window item from the
File menu.

Moving a window

You can move a window anywhere on the screen by dragging its title bar. By
changing the position and the size of windows, you can arrange windows in
any way that works best for you.

To move a window:

1 Point to the title bar of the active window (anywhere on the title bar except the close box
or the zoom box).

2 Drag the title bar in any direction, and then release the mouse button.

When you drag a window’s title bar, an outline of the window follows the
pointer on the screen. When you release the mouse button, the window itself
moves to the position of the outline.
Notice that the active window stays in front of other windows if the windows
overlap.
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Working with menus

Menus come in two types: pull-down menus and pop-up menus. The menus in
the menu bar are pull-down menus, as illustrated in the following figure.

The Help menu
Used to display information 
about items on the screen

Menu bar
You pull down menus
from here

Menu titles.

The Application menu
Shows the programs
that are currently open

A selected icon
Menu commands
affect whatever 
you’ve selected

Dimmed command
Not available

The Edit menu
Pulled down

Pop-up menus often appear in special windows called dialog boxes, which you
use to set options or preferences. You can recognize a pop-up menu by a
small, solid, downward pointing triangle next to its name. The name shows the
current option or preference. A pop-up menu is shown in the next figure.

Pop-up menu (closed)
Clicking the triangle or the menu title
displays the menu and allows you to
choose a menu item.
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Choosing an item from a menu

To choose an item from a menu, point to the menu name, press to “pull down”
or “pop up” the menu, drag to the item you want to choose so that it’s
highlighted, and then release the mouse button.

Some menu items allow you to display subordinate menus called submenus. A
menu item containing a submenu has a small, solid triangle next to it, pointing
to the right. The submenu appears when you highlight the menu item
containing it.

To choose an item from a submenu:

1 Point to the menu name and press to pull down or pop up the menu.

2 Drag to the menu item so that the submenu appears.

3 Drag sideways to the submenu, drag to the submenu item you want to choose so that it’s
highlighted, and then release the mouse button.

Using keyboard shortcuts

Rather than choosing an item from a menu, you can often use a keyboard
shortcut to perform the same function as the menu item. These shortcuts
involve a combination of keypresses and always involve the use of at least one
modifier key, such as the COMMAND (x) key or the OPTION key. Some
common keyboard shortcuts are shown in menus to the right of the menu items
that they correspond to. The following table lists popular shortcuts.

Using keyboard shortcuts 13



Keypress Action

x–N Creates a new folder or in some programs, this shortcut creates a new
document.

x–O Opens the selected item.

x–W Closes the selected item.

x–D Duplicates the selected item.

Arrow key Selects the next item in the direction of the arrow (up, down, left, or right ).

TAB key Selects the next item alphabetically (except in the Chooser).

Character key (A, B, C…) Selects the first item whose name begins with the that character (or the
character following closest to it in the alphabet)

x–DOWN ARROW Opens the selected icon.

x–OPTION–DOWN ARROW Opens the selected icon and closes the current folder.

x–UP ARROW Opens the folder that contains the current folder.

x–OPTION–UP ARROW Opens the folder that contains the current folder, and closes the current folder.

x–OPTION–O Opens the selected folder and closes the current folder.

RETURN or ENTER In the Finder: Selects the selected icon’s name for editing, or saves the
edited name.

In a dialog box: Has the same effect as clicking the button with the bold outline
around it..

Using the Trash

When you no longer need or want a file or folder, you throw it away by
dragging its icon to the Trash (an icon of a trash can in the lower-right corner
of the desktop). When you put a file or folder in the Trash, the Trash icon
bulges to indicate that it is no longer empty.  At this point, you can open the
Trash (by double-clicking its icon or by selecting it and choosing the Open
command from the File menu) and examine its contents.

When you want to permanently remove the contents of the Trash, choose
Empty Trash from the Special menu. The Trash icon no longer bulges,
indicating that it is empty. Once you empty the Trash, the items are
permanently removed from your system. Until you choose Empty Trash, you
do not free any space on your hard disk.
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Working with programs

This section provides general information about working with programs. For
specific information about a particular program, see the manuals that came
with the program.

To practice using a program to create a document and save your work, you can
use TextEditor, a simple word-processing program that comes with
your computer.

Opening a program

The easiest way to open a program is by double-clicking its icon. Position the
pointer on the program’s icon and then press and release the mouse button
twice in quick succession without moving the mouse.

You can also open a program by using the File menu. For example, you would
follow these steps to open the TextEditor program:

1 Click the program icon once to select it.

2 Point to the File menu name in the menu bar.

3 Press to pull down the File menu.

4 Drag to the Open item (the second item in the File menu) so that it is highlighted, and
then release the mouse button.

When you choose the Open command, the selected icon opens into a window.
The icon itself becomes filled in with a pattern of dots, indicating that it has
been opened.

When you open the TextEditor program, the following events occur:
n An untitled window opens.
n The TextEditor menu names appear in the menu bar.
n The Application menu icon at the right end of the menu bar becomes the

TextEditor icon.
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Creating a document

The untitled TextEditor window you just opened is like a blank sheet of paper,
a document waiting to be created. In the upper-left corner of the empty
document is a blinking vertical line. The line is called the insertion point
because it marks the place where the text you type will be inserted. As you
type text, you can use the mouse to move the insertion point to any place in
your document.

Selecting text

You can select text in your document in several ways. You can select a single
word by double-clicking it.

To select a block of text:

1 Move the pointer over the text.

Notice that the pointer changes shape from an arrow to an I-beam.

2 Position the I-beam just to the left of the first word of the text you want to select.

3 Press and hold down the mouse button, and drag across the text until all the text you
want is highlighted.

4 Release the mouse button.

The selected text remains highlighted. With this text selected, you can modify
it in any way you like.

With the mouse button
down, drag from here… …to here.
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Changing text

When you are creating or modifying a document, you can delete, duplicate, or
move text in your document and between several documents. To do this, you
use the Cut., Copy, and Paste commands in the Edit menu

n To delete text, select the text and choose Cut from the Edit menu or press COMMAND-X.

n To duplicate text, select the text and choose Copy from the Edit menu or press
COMMAND-C.

Once you have cut or copied text, it is stored on the Clipboard—a temporary
location in memory—and you can place it in other parts of your document or
in other documents. To move text, first cut or copy the desired text and then
place the insertion point where you want the text to be added (that is, move the
I-beam to the new location and click). Then choose Paste from the Edit menu
or press COMMAND-V. Chapter 5, “Working With TextEditor,” discusses
these operations in detail and provides examples.

Saving your work

Until you save your work, it exists only on the screen and in the computer’s
temporary memory. Unless you tell the computer that you want to save your
changes, they are lost when you turn off your computer or quit the program.

To save your work:

n Choose Save from the File menu, or press COMMAND-S.

If you have not already named the file in which to save your work, a directory
dialog box appears, asking you for a name for your file. Enter a name and
click Save.

A directory dialog box allows you to view contents of disks and folders so that
you can save a document in a particular folder or disk, or open a document
that’s in a particular folder or disk. A directory dialog box appears when you
choose Save for the first time or whenever you choose Save As or Open from
a program’s File menu.
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Switching programs

You can have several programs open at one time. The number of programs
depends on how much memory your computer has. However, only one
program at a time can be the active program—the active program is the one
whose window is in front of the other open program windows.

For example, when you open TextEditor, that program is the active program
and the TextEditor window is the active window. But TextEditor is not the
only program running. The Finder (the program that displays the desktop) is
also open, but right now it is not active.

Use either of these methods to switch between programs that are open:

nnnn Click anywhere in a window to make it the active window and its program the
active program.

nnnn Choose the name of the program from the Application menu.

The Application menu lists all of the programs that are currently running and
allows you to switch between them. This menu is located in the right corner of
the menu bar.

Closing a document

When you close a document, you do not close the program that you used to
create it. (Closing a program is called quitting.) The program remains open
and remains the active program until you quit the program or make another
program the active program.

To close a document:

1 Make the document’s window active by clicking anywhere in the window.

2 Click the window’s close box (near the left end of the title bar) or choose Close from the
File menu.

Respond to any messages that appear by clicking the appropriate buttons.
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Quitting a program

Quitting a program closes the program as well as any documents you may
have open that were created with that program. Quitting a program is not the
same as closing a document. Closing a document leaves the program open and
active.

To quit a program:

1 Ensure that the program is the active program.

Click in a window belonging to the program, or, if no such windows are open,
choose the program from the Application menu.

2 Choose Quit from the File menu, or press COMMAND-Q.

Respond to any messages that appear by clicking the appropriate buttons.

Making a copy of a document

It is often convenient to make a copy of a document so you can preserve the
original while making changes to the copy. You can copy a document while
using the Finder, without having to open the program that created it.

To copy a document:

1 Click the document’s icon to select it.

2 Choose Duplicate from the File menu, or press COMMAND-D.
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Changing the name of an icon

You can change the name of an icon to anything you like. An icon name can
contain any combination of characters—including spaces, uppercase and
lowercase letters, and numbers—except the colon (:) character. When you
open a renamed icon, the new name appears as the title of the window.

To rename an icon:

1 Click the name (not the icon itself) that you want to change.

When the name is selected, it is highlighted and a box appears around it. The
arrow pointer becomes an I-beam pointer.

2 To replace the entire name, simply type the new name. To change part of the name,
use the I-beam pointer to select the characters you want to change, and then type
your changes.

The text that you type replaces the selected text.

Using Balloon Help

The Apple Workgroup Server 95 comes with an on-screen help system called
Balloon Help. You can display Balloon Help information any time you don’t
understand the instructions in this guide—or if you see a window, button,
menu, menu item, or icon that you want to know more about.

To use Balloon Help:

1 Choose Show Balloons from the Help menu.
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2 Position the pointer over the item you want to know more about.

A balloon appears with an explanation of that item.

You can turn off Balloon Help at any time by choosing Hide Balloons from
the Help menu.
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2 Getting Started With A/UX 3.0.1

This chapter introduces A/UX and covers the following topics:
n starting a work session
n logging in to A/UX
n changing your password
n working in a command-line environment with the CommandShell

application
n viewing alert and error messages in the A/UX System Console window
n logging out of A/UX
n shutting down A/UX



Introduction to A/UX

A/UX, the operating system for the Apple Workgroup Server 95, joins two
systems that have different histories and different styles of operation. They
are the UNIX operating system and the Macintosh Operating System. In
practical terms, this means that with A/UX you use the UNIX operating
system through the Macintosh user interface. You use Macintosh icons and
mouse operations to manipulate the commands and utilities that give UNIX
its flexibility and power.

While you are running A/UX, the Finder allows you to open files and
folders, close them, copy them, and move them, and to perform a variety of
other functions as well. You can use the Finder to manipulate files and
folders. This is true whether they are stored in a UNIX file system or in a
Macintosh file system.

Starting A/UX

When you press the POWER ON key to start up the computer, the A/UX
Startup program begins to run A/UX. A series of screens appear, each
screen containing a progress bar to inform you of the progress of the
startup sequence. One of these screens is shown here.

The A/UX Startup program checks the condition of the UNIX file systems
each time you start A/UX and fixes problems identified during the check.
For example, problems can be caused if the system was shut down
improperly the last time it was used. This check can last for several minutes.

Note:  While the A/UX Startup program is starting A/UX, the screen might
flicker or even become blank for a moment. However, the progress bar
should reappear quickly and the process should continue.
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While A/UX is starting, a Cancel button appears at the right end of the
progress bar. You can halt the Startup program by clicking the Cancel button.

The Cancel button changes to a Messages button after a few seconds. If
you click the Messages button, a small window appears that displays status
messages describing the progress of the startup process.

IMPORTANT   A/UX might display advisory messages during the startup
sequence. In some cases, you must supply information in response to the
message. If this happens, an alert box appears and tells you that there is a
message for you. When you click the OK button in the alert box, the A/UX
System Console window opens. In this window, you can see the messages
and enter any information that the program requests.  For further
information on the A/UX System Console window, see “Using the A/UX
System Console Window” later in this chapter and Server Administration
With A/UX 3.0.1.

By default, the Apple Workgroup Server 95 starts up in the Finder
environment for the root account. (See the next section, “Logging In to
an Account,” to learn how to change the default.) The Finder environment
that appears after startup contains several important elements. The file
hierarchy icon, labeled with a slash (/) character, represents the disk area for
file systems and important applications. The MacPartition icon represents
the A/UX Startup program and important startup files. If you log in to a
user account, the system also displays a folder that allows you to quickly
access your home directory.

File hierarchy icon

MacPartition icon

Home directory folder
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Logging in to an account

When it is shipped, the Apple Workgroup Server 95 is set up so that you do
not need to log in to A/UX. When the server starts up, you are automatically
placed in the Finder environment for the account whose name is found in
the Autologin file. The Autologin file can contain no more than one
entry. By default, this entry is root. This entry tells the system to
automatically log you in to the root account at startup. You can change
the account name in this file to the name of another account if you prefer
the system to log you into another account at startup. You can also require
users to log in to the system by deleting the entry in the Autologin file,
leaving the file empty. (For information about editing text files such as the
Autologin file, see Chapter 5, “Working With TextEditor.”)

The Autologin file is located in the Preferences folder of the Login
System Folder. (The Login System Folder is found in the sys folder of the
mac folder on the hard disk labeled with a slash.)

As shipped, A/UX contains a Guest account, to which anyone can log in,
and a start account, that is used for tutorial purposes. In addition, your
system administrator may have created a user account that is meant for
your personal use.

The start account and the Guest account can be used by several users,
although your system administrator may require use of a password for
logging in to those accounts in order to limit the number of people who
have access to them. As shipped, the password for the start account is
my.password and the guest account has no password. (For information on
creating accounts, see Server Administration With A/UX 3.0.1.)

If your system is configured for logging in, the Login dialog box, shown in
the following figure, appears as soon as A/UX Startup has started A/UX.
You can log in whenever the Login dialog box is on the screen.
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To log in to an account:

1 Click the Registered User button in the Login dialog box, unless it is already selected.

2 Type your login name in the Name text box.

If you are logging in to the root account, type root. If you are logging in
to a user account, type the login name. Remember to enter the login name
exactly as specified, using lowercase letters unless uppercase letters are
indicated.

3 Press RETURN.

The text insertion point moves to the Password text box. You can also move
the insertion point by pressing the TAB key or by clicking in the Password
text box. Each user account has its own password to ensure system security.
(For information on changing your account password, see “Changing
Your Password” later in this chapter.)
If your user account was created without a password, you may be asked to
assign your own password by typing it in the space provided.

4 Type your password in the Password text box.

A gray rectangle expands through the Password text box as you enter each
character. The characters are hidden from view to prevent others from
reading your password.

IMPORTANT   Like UNIX, A/UX is case sensitive—that is, it distinguishes
between uppercase and lowercase letters. Therefore, if your password
consists of all lowercase letters, the system won’t recognize it if you type it
with any uppercase letters.
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5 Click the Login button or press RETURN.

If you make a mistake while typing your login name or password, double-
click the Name or Password text box to select the text; then press the
DELETE key.
Type the login name or password again, and click Login or press RETURN.
If the password and the login name are correct, the system logs you in and
the desktop appears after a few moments.

Changing your password

If your system is set up for logging in, you can change your password. Use
a password that you can remember without writing it down. Don’t use a
password that is easy to deduce, such as your name spelled backward, your
computer login name in uppercase letters, or the name of a family member.
You should change your password from time to time for additional
security. To change your password:

1 Display the Login dialog box.

If you are already logged in, choose Logout from the Finder’s Special
menu to display the Login dialog box.

2 Choose Change Password from the Options menu.

The Change Password dialog box appears.
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This dialog box lists the special restrictions that apply to the characters you
can use in a password. If your system administrator overrides these
requirements, a description of them does not appear in the dialog box.

3 Enter your login name.

4 Enter your old password.

5 Enter your new password.

Another dialog box appears, asking you to confirm your new password.

6 Enter your new password again.

The Login dialog box reappears with the Name and Password text boxes
filled in. You can use the Options menu again before completing the login
process, if necessary.

7 Click the Login button in the Login dialog box.

The system logs you in to A/UX, and your new password takes effect. You
must enter it the next time you log in.

Using CommandShell

CommandShell is a program that allows you to display one or more
windows in which you can communicate with A/UX by entering commands
on a command line, as is traditionally done on most UNIX systems. When
you use CommandShell, you communicate with A/UX through a utility call
a shell. Like the Finder, a shell establishes an interface between you and the
operating system. It accepts the commands that you enter and passes them
on to the operating system, which executes them. It also displays the
operating system’s responses.

There are several standard shells, each of which interprets your commands
and the operating system’s responses somewhat differently than the others.
For more information on CommandShell, see Server Administration With
A/UX 3.0.1.
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Making CommandShell active

Before you start CommandShell, the Finder should be the active program.
(Its menu bar should appear at the top of the screen.)

To make CommandShell active:

n Choose CommandShell from the Application menu, which is at the right side of the
menu bar.

A window labeled “CommandShell 1” appears and becomes the active
window.

When the CommandShell window becomes active, the CommandShell
menu bar appears. It contains commands that allow you to manipulate the
CommandShell windows and their contents.
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Switching between CommandShell and the Finder

You can return to the Finder by clicking on any portion of a Finder
window or by choosing Finder from the Application menu. When you
make the Finder the active application in this manner, CommandShell
remains open. You can make CommandShell active again by clicking on
any portion of a CommandShell window or by choosing CommandShell
from the Application menu.

IMPORTANT   The folder that you are using in the Finder does not determine
the directory in which your CommandShell windows are working.

Using the A/UX System Console window

When you are working in the A/UX environment, the system may generate
messages regarding its status. In a traditional UNIX environment, these
messages appear on a console terminal. Typically, the system administrator
monitors these messages, which alert the administrator to take action to
avert or remedy a problem. In A/UX, the system messages appear in the
A/UX System Console window, a CommandShell window that you display
by choosing its name from the Window menu when CommandShell is
active.

Displaying the A/UX System Console window

To view the contents of the A/UX System Console window:

1 Choose CommandShell from the Application menu.

A CommandShell window becomes active and the CommandShell menu
items become available.

2 Choose A/UX System Console from the Windows menu, or press COMMAND-0 (that is, the
number zero).

The A/UX System Console window opens. For information on the messages
that may appear in the window, or for information on how to respond to a
request for information, see Server Administration With A/UX 3.0.1.
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Clearing the A/UX System Console window

You should clear the messages from the A/UX System Console window
periodically so that you can tell when new messages appear.

To clear the A/UX System Console window:

n Choose Clear Lines Off Top from the Commands menu.

All the information in the window disappears.

Closing the A/UX System Console window

You use the close box to close the A/UX System Console window, just as
you would to close any other window. Note that when you close the A/UX
System Console window, none of the information in the window is lost.
Closing the System Console window is equivalent to “hiding” it.

How A/UX notifies you of an alert message

If A/UX needs to bring an alert message to your attention, an icon flashes
in the menu bar and an alert box appears. If CommandShell is not the
active program, a diamond-shaped symbol also appears alongside the
CommandShell item in the Application menu. Choose this item to activate
CommandShell; then choose A/UX System Console from the Windows
menu to display the alert message.

You can change this default behavior to suppress the alert box, the flashing
menu-bar icon, or both.

To change how A/UX notifies you of an alert message:

1 In CommandShell, choose Notification Levels from the Preferences menu.

A dialog box like this one appears.
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2 Click the appropriate buttons and then click OK.

Using CommandShell to monitor errors
If you are using your Apple Workgroup Server 95 as an AppleShare server,
the reporting of many system problems is more comprehensive. By storing
system messages in a scrolling window available on the server only, A/UX
preserves system errors for future reference. An example of a system
message is the message that a disk is full. Such a message would be
generated after each failed attempt to place data on a server volume by any
client anywhere on the network. As in any other type of AppleShare server
configuration, the client would also receive an alert box in the event of a
disk-full error.

The system administrator receives the added value of being directly
informed of such errors at the server location because the A/UX System
Console window is updated with a corresponding but brief A/UX error
message. The previous section tells you how to display these messages. For
more detailed information on CommandShell, see Server Administration
With A/UX 3.0.1.

IMPORTANT   The error notification feature will be disabled if you quit
CommandShell. The program must be running in order for error messages
to be properly routed to the System Console window. To leave
CommandShell running while you use the desktop for other work, choose
Hide CommandShell from the Application menu. Do not choose the Quit
command.
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Logging out

Logging out is a simple way of ending your work session on the Apple
Workgroup Server 95 without shutting down the computer. Logging out
allows you to leave the server in a secure state requiring the next user to log
in.

If you have deleted the account name from the Autologin file, the Login
dialog box will appear when you log out. If you have not deleted the entry
in the Autologin file, you are immediately logged back in to the system.
Setting up your system this way provides a convenient way to restart the
Finder without shutting down A/UX.

To log out of your account:

1 Choose Finder from the Application menu to be sure that the Finder is the active program.

The Application menu appears when you click the icon at the right end of
the menu bar.

2 Choose Logout from the Special menu.

The system reminds you to save all your unsaved work.

After you log out, the Login dialog box reappears, indicating that you have
logged out successfully. The computer remains on and A/UX is still
running.
Note:  If you are using AppleShare Pro, logging out cancels your active
programs.

Shutting down A/UX

Sometimes you need to shut down the server to do system maintenance,
such as adding peripheral devices or repairing a file system. You must have
root privileges to shut down the computer.

WARNING  Don’t manually turn off the computer while A/UX is
running. Doing so may corrupt the file system and cause loss of data.
Always use the correct shutdown proceduire to turn off the computer.
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To shut down A/UX:

1 With either the Login dialog box or the desktop displayed, choose Shut Down from the Special
menu.

If you want to shut down and start up again immediately, choose Restart
instead of Shut Down. The Restart dialog box appears. If you are not
logged in to the root account, you will be prompted for the password for
that account.
If you are the sole user of your system, the system shuts down. If other
users are using your server, the Shut Down dialog box appears.

2 If others are using the system or its services, type a warning message in the text box of the
dialog box.

Your message will be sent to other users to warn them that the system is
shutting down.

3 Type a number specifying the delay, in minutes, between the time the message is transmitted
and the time at which the other users must finish logging out.

Give the other users a reasonable amount of time to save their work and to
log out.

4 Click the Shut Down button.

After the delay you have specified, the system shuts down. (If you are
working in the Restart dialog box, click the Restart button; after the
specified delay, the system restarts.)
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3 Using Files and Folders

This chapter helps you work with the files and folders on your Apple
Workgroup Server 95. It introduces you to the various icons that appear on the
Finder desktop and then tells you how to
n create, name, and save files and folders
n organize files on the desktop
n search for files
n work with aliases
n obtain special information about a file, such as when it was created and

whether it is locked
n control the way files are listed in a window



The Finder icons in A/UX

This section identifies the various objects that appear on the desktop when you
use the Finder in the A/UX environment and explains how you use them.

The A/UX operating system contains many files, folders, and application
programs, each of which is represented by an icon in the Finder.

Folder icons

This section illustrates the different folder icons that may appear in the desktop
environment.

Folder  An icon that resembles either of these two icons
represents a folder for which you have read permission—
that is, the ability to open the folder and see what files or
folders are in it. You may or may not have write
permission for the folder—that is, the ability to add,
rename, or remove items. A marked tab like the one on
the folder labeled start.bak indicates that you own the
folder, which means that you created it or that ownership
has been transferred to you.

Locked folder  This icon indicates that you cannot open
this folder, nor can you change any of its contents.

Drop box  This icon represents a folder for which you
have write permission only. You cannot open the folder or
read the files in the folder, but you can place files in it.

Active System Folder  This icon represents the System
Folder that the system is currently using.
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Home directory folder  This icon represents the alias of
your home directory folder. If you are in an account other
than root, this icon appears automatically at the right
edge of the desktop. The name of the folder is normally
your login name and the word alias. (Aliases are
discussed later in this chapter.)

File, program, and utility icons

The following icons represent various kinds of files in A/UX. They include
files that are commands, scripts, programs, and text documents.

A/UX text files  An icon that resembles one of those
shown here represents a text file for which you have read
permission (top) or one for which you do not have read
permission (bottom). When you double-click an icon that
resembles the icon labeled passwd, the file opens, along
with the default text editor. You cannot open a file
represented by an icon like the one labeled john, because
you do not have read permission.

Binary data file  This icon represents a file that is not a
text file; it contains code that can be read only by the
computer or by a program. You can neither read nor
execute this file.

A/UX command  This icon represents a UNIX command.
UNIX commands are described in Server Administration
With A/UX 3.0.1.

The Finder icons in A/UX 39



Shell script  This icon represents a shell script, often
called simply a script. A script is an executable text file
that contains a series of commands for the computer to
carry out. Many scripts are created by system
administrators and by users on site and are not an integral
part of the A/UX operating system. Note the similarity
between this icon and the A/UX command icon shown
earlier.  For information on creating scripts, see A/UX
Shells and Shell Programming, available with the A/UX
3.0 documentation suite.

Executable file (without read permission)  This icon
represents an application program that you can run, but for
which you do not have read permission. Many programs
(such as those supplied by other manufacturers) are
represented by custom-designed icons, which appear in
place of this icon.

HyperCard program icon  This icon is an example of a
Macintosh program (the HyperCard® program). On
A/UX, you can start a Macintosh program such as
HyperCard by double-clicking the icon.

File-system icons

This section describes icons that represent UNIX and Macintosh file systems.
Server Administration With A/UX 3.0.1 discusses UNIX file systems in more
detail.

UNIX file system (or / folder) icon  This icon represents
the root level of the UNIX file system.  For a discussion
of the traditional representation of the UNIX file system
as an inverted tree, see Server Administration With A/UX
3.0.1.
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Macintosh file system  This icon represents a partition or
a hard disk that contains a Macintosh file system.

Macintosh floppy disk  This icon represents a floppy disk
formatted with the Macintosh file system. The system
does not display an icon for a floppy disk that is formatted
with a UNIX file system or that contains UNIX data. You
have access to such a floppy disk only by entering UNIX
commands in CommandShell.  For more information on
UNIX commands and CommandShell, see Server
Administration With A/UX 3.0.1.

Using files and folders in the Finder

In traditional UNIX terminology, the term directory is used for the object that
is called a folder in the Macintosh environment. Consequently, in traditional
UNIX terms, a file system contains directories, which, in turn, can contain
files and other directories. The UNIX file systems supported by A/UX follow
the same structural paradigm.

Although people working in the CommandShell environment find it useful to
think in traditional UNIX terms, and refer to directories rather than folders,
those who are using the Finder prefer to think in terms of folder and file icons.
Because the Finder is discussed in this section, the term folder is used
consistently here.

The Finder has a few rules and limitations. When you name or rename files
and folders, observe the following restrictions:
n Names can contain no more than 31 characters.
n Names cannot contain colons (:). In the Finder, colons indicate the next

item in a pathname. If you try to use a colon, the Finder converts it to a
hyphen.
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Creating and naming folders

Most programs let you create and name a new folder in the directory dialog
box that appears when you first save a document or when you choose Save As
from the File menu.

To create and name a new folder when the Finder is active:
1 Choose New Folder from the File menu.

A new folder icon named “untitled folder” appears in the active window (or on
the desktop if no window is active). The name is already selected.

2 Type a name for the folder and press RETURN.

You open, move, copy, and remove folder icons in the same way that you do
any other icons.

Saving your files in different locations

The first time you save a document that you’re creating with an application
program, a directory dialog box appears.

You use the directory dialog box to name your document and specify where to
store it. Directory dialog boxes vary slightly from program to program, but
every directory dialog box has certain common features.

Name of the current
hard disk or floppy disk

Use this button to move
to the desktop level and
change the current disk.

Text box for naming a file
or changing its name

Pop-up menu for moving upward in the
file levels. The current directory is shown.

Directory list
Double-click a folder
icon or disk icon to open
it and view its directory.
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The dialog box always contains a pop-up menu that allows you to view the
directory path for the file and determine where to store the file. The pop-up
menu has a small, solid triangle, pointing down, next to its name. The menu
name indicates the folder in which to save the file. In the preceding figure, the
folder is Status Reports. You can change folders by selecting a folder from the
list below the pop-up menu or by choosing a different folder from the pop-up
menu.

Rearranging icons on the desktop

Choose the Clean Up item from the Special menu to “straighten up” the icons
in the active window or on the desktop. (The wording of the Clean Up item
changes depending on which icons are active or selected.)

To arrange icons alphabetically by name or according to the list view
displayed most recently in that window, hold down the OPTION key while
choosing Clean Up Window.  Holding down the OPTION key also moves the
icons toward the upper-left portion of the window.

When the item is Clean Up All, you can line up all of the icons near the right
edge of the screen by holding down the OPTION key while choosing Clean Up
All.

If one or more icons are selected, holding down the SHIFT key while choosing
the Clean Up item rearranges the selected items only.

Finding a file or a folder

When the Finder is the active program, you can use the Find item in the File
menu to find a file or folder on any disk whose icon is on the desktop. (The
Find item cannot locate files inside the System file, such as fonts and sounds.
You must open the System file to see its contents.)
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Finding an item by name

To find a file or folder by name:
1 Choose Find from the File menu, or press COMMAND-F.

A Find dialog box appears.
2 In the text box, type the name (or part of the name) of the file or folder you want to find.

It doesn’t matter whether you type uppercase or lowercase letters, as long as
the letters that you type are in the name of the item you’re looking for.

3 Click the Find button.

The first item that matches the name (or partial name) that you typed appears,
highlighted, in a Finder window. If no match is found, your computer emits an
the alert sound.

4 To see the next matching item, choose Find Again from the File menu, or press
COMMAND-G.

If no more matches are found, your computer emits an alert sound.

Finding a file or folder by characteristics other than name

You can use the Find command to find a file or a folder by searching for its
size, its label, the date it was created or modified, or other characteristics.

To Find an item by a feature other than name:
1 Choose Find from the File menu.

A Find dialog box appears.
2 Click the More Choices button.

The dialog box that appears lets you set different search characteristics
through pop-up menus; together, these characteristics form a search order.
The contents of the middle pop-up menu and the text area vary according to
the item selected in the left pop-up menu.

3 Press the pop-up menu on the left to open it, drag to choose an item, and then release
the mouse button.

4 Press the pop-up menu in the middle to open it, drag to choose an item, and then release
the mouse button.

5 Adjust the date, choose an item, or type text in the upper-right area of the dialog box.
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6 Choose a search location from the pop-up menu labeled Search.

You can choose to search all disks, a specific disk, or the active Finder
window.

7 If you want all found items displayed at once, click the checkbox labeled “all at once” so
that an X appears.

8 Click the Find button when you have finished setting your search characteristics.

The first item that matches your search characteristics is shown highlighted in
a Finder window. To see the next item found, choose Find Again from the File
menu (or press COMMAND-G).
When the items found are displayed all at once, they are shown highlighted in
one or more Finder windows.

Finding files and folders through a two-stage search

You can use two sets of characteristics and locate the files and folders that
meet both sets of characteristics.

To find items matching two search requirements:
1 Choose the first set of characteristics that you want to search for.

2 Click the “all at once” checkbox so that an X appears.

When this option is selected, the items that are found will be displayed
(highlighted) in a list.

3 Click the Find button.

The items found are shown highlighted in a Finder window.
4 Choose Find from the File menu again, before you click or take any other action.

You choose Find before taking any other action so that the items located in the
first stage of the search remain highlighted.

5 Choose the second set of characteristics that you want to search for.

6 Choose “the selected items” in the Search pop-up menu.

7 Click Find to begin the second stage of your search.

The search is limited to the items found in the first stage, and only those
matching both sets of characteristics are highlighted.

Finding a file or folder 45



Uses of the Find menu item

The Find menu item can help you locate files quickly, organize large
quantities of documents, and develop an efficient system for backing up and
archiving your work. The following table shows examples of how you might
use the Find menu item.

Search characteristic What can be located

Name Files whose names you can’t recall exactly.

All files and folders for which you use a standard name, such as status
reports or expense reports.

Files whose locations you have forgotten.
Kind All application programs.

All aliases. (Aliases are described in the next section.)
Size Large files, to make space available on a disk.
Label All files to which you added the same label (such as “top secret”). See

Chapter 7, “Customizing the Finder Environment,” for information about
labeling.

Lock Locked files, to unlock them for editing.
Modification date All files changed since a certain date, for regular backup of new and

changed files.
Creation date All files created before a certain date, for archiving or erasing outdated

material.
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Using an alias

An alias is a pointer that you can place in any folder to represent a program or
document. When you place an alias in a folder, you are not copying the actual
program or document into the folder; you are simply placing an icon in the
folder as a signpost. An alias points to the original file that it represents, so
when you open an alias, you’re actually opening the original file. Any changes
you make to the file and save are stored with the original file. An alias can
serve as a signpost to a file, a folder, a disk, and other kinds of items—even a
shared item that you use over a network. You can make as many aliases for an
item as you want.

Creating an alias

To create an alias:

1 Select the item for which you want to make an alias.

2 Choose Make Alias from the File menu.

The alias icon appears on top of the original. Its name is in italics and ends
with the word alias. The name is already selected.

3 Change the name of the alias if you want to, and then move it to wherever you want to
put it—in a different folder, for example, or on the desktop.

You may want to place the alias in the Apple Menu Items folder in the System
Folder. Placing an alias in this folder allows you to open the original file by
using the Apple menu at the left end of the menu bar.
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Locating the item to which an alias points

You can locate the item that an alias represents by opening the alias’s Info
window.

To find the item to which an alias points:

1 Select the icon of the alias for which you want to find the original item.

2 Choose Get Info from the File menu.

The alias’s Info window appears.

3 Click the Find Original button.

The window containing the original item opens, with the item’s icon
highlighted.

If you have deleted the item that the alias represents, a message appears,
reporting that the original can’t be found. Aliases are not deleted when the
original files are deleted.

Moving an item onto the desktop

You can make an item easy to find by dragging its icon to the desktop from
any window. The icon stays on the desktop until you remove the disk on
which the item is actually stored.

If you’ve placed an icon on the desktop, you can put it back in its original
location by selecting it and then choosing the Put Away item from the File
menu.

Getting information about a file

When you’re working on the desktop, you can choose the Get Info item from
the File menu to display information about a file, such as when a document
was created or how much memory a program needs.

To get information about a file:

1 Select the item for which you want information.
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2 Choose Get Info from the File menu, or press COMMAND-I.

A window appears, displaying descriptive information.

You can use the Info window for several purposes in addition to obtaining
information. You can use it to lock a file (so it can’t be changed or thrown
away), turn a document into a stationery pad, change a program’s memory
allocation, and change the file’s icon. (See Chapter 7, “Customizing the Finder
Environment,” for information on the last procedure.)

You can type comments in the Info window and later search for them with the
Find item.

You can also use the View menu, described later in this chapter, to see certain
types of information about the files listed in a Finder window.

Locking a file

You use the Get Info item to lock a document or program. Locking a program
may affect its operation. Locking a file prevents it from being thrown away or
being altered.
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To lock a file:

1 Select the item and choose Get Info from the File menu.

The file’s Info window appears, as shown in the previous section.

2 Click the Locked checkbox in the lower-left corner so that an X appears.
Note:  You can’t lock a folder, but you can lock the items in a folder, including
the contents of folders that you’re sharing on a network. You can lock an alias,
but doing so does not lock the original file. Locking an alias merely protects it
from being thrown away.

Using the View menu

You can use the View menu to display the contents of a window by icon or by
small icon, or according to name, size, kind, date, or label. (See Chapter 7,
“Customizing the Finder Environment,” for information on using the Views
control panel to change how files are listed and what information is included.)

Windows are set initially to show items by icon. One of the other views (small
icon, name, size, kind, label, or date) can be useful when you have too many
files to see easily as icons, or if you want your files arranged according to a
particular attribute. For example, listing documents by the date and time of
their most recent modification makes backing up files an orderly task.

When the contents of a window are displayed as a list and you want them
arranged in another list view, you don’t have to use the View menu. As a
shortcut, you can click a column heading (such as Size or Last Modified) to
rearrange the list according to that heading.

The type of list displayed is underlined.
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4 Backing Up Your Work With Disks or Tape
Cassettes

This chapter describes how to work with floppy disks and tape drives. It
tells you how to
n format, lock, copy, and eject floppy disks
n back up files from your hard disk to a floppy disk
n restore files onto your hard disk
n work with and maintain your tape-backup unit



Working with disks

This section tells you how to use floppy disks and hard disks with your
Apple Workgroup Server 95, how to make backup copies of critical files on
floppy disks, and how to restore the files to your hard disk.

It is important that you make backup copies of individual files as you
create and revise them, and that you back up the entire system periodically.
Making backups prevents you from losing data or programs should your
disk or your system fail. For information on backing up your entire
system, see Server Administration With A/UX 3.0.1.

Formatting floppy disks for a Macintosh file system

Before you can use a brand-new floppy disk, you must perform a
procedure known as formatting. During formatting, the computer writes
information onto the disk, enabling it to accept either a Macintosh or a
UNIX file system. For information about formatting floppy disks for a
UNIX file system, see Server Administration With A/UX 3.0.1.

If you insert a floppy disk that has already been formatted for a Macintosh
file system, its icon appears near the right edge of the screen. The icon will
resemble the one shown here.

If the floppy disk has not been formatted for a Macintosh file system, your
server displays a series of alert boxes to guide you through the formatting
process.
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To format a floppy disk for a Macintosh file system:

1 Insert the disk.

An alert box appears, telling you that the disk is unreadable. For high-
density disks, the following alert box appears.

For 800K disks, this alert box appears.

You can cancel the formatting process and eject the disk by clicking the
Eject button.

2 For high-density disks, click the button labeled Initialize in the alert box. For 800K disks, click
the button labeled Two-Sided in the alert box.

The next alert box appears.

3 Click the Erase button.

Click Cancel if the disk contains data that you don’t want to erase.
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Locking a floppy disk

You can protect the contents of a floppy disk by locking it. When a floppy
disk is locked, you can examine the contents but cannot initialize the disk
or remove any of the information on it. To lock a floppy disk, use your
thumbnail or a push-pin to slide the tab on the back of the disk so that the
square hole is open. To unlock the disk, slide the tab back so that it covers
the square hole.

 

Locked Unlocked

Copying a file from a hard disk to a floppy disk

One way to transport or back up files is to copy them to floppy disks.
When you are working on the desktop, you can copy a file from your hard
disk to a floppy disk by dragging its icon.

To copy a file or folder to a floppy disk:

1 Insert a floppy disk (formatted for a Macintosh file system) into the disk drive.

An icon representing the disk appears on the desktop.

2 Drag the icon of the file or folder that you want to copy to the floppy disk icon. Release the
mouse button when the disk icon is highlighted.

An alert box appears, describing the progress of the copy operation.

You can SHIFT-click to select multiple files or folders to copy.
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You can back up the work you store on a hard disk by copying individual
files to another disk in the usual way (dragging their icons to the icon of
the other disk). You can back up the contents of an entire floppy disk by
dragging its icon to another floppy disk icon or to a hard disk icon.

You can also use a commercial backup program, such as Retrospect
Remote, to copy some or all files from a hard disk to another hard disk, to
a tape drive, or to a series of floppy disks. If your server is equipped with
the optional tape-backup unit, see the section “Working With Tape
Cassettes” later in this chapter.

Restoring a file from a floppy disk to a hard disk

A/UX provides an easy way to restore files or folders that were backed up
by dragging their icons to a disk.

To restore a backed-up file:

1 Insert in the drive the floppy disk containing the file you want to restore.

An icon representing the disk appears on the desktop.

2 Double-click the disk icon to display a window that shows the contents of the disk.

3 Select the icon of the file or folder that you want to restore and drag it to the folder on the
hard disk on which you want it to reside.

An alert box appears, describing the progress of the copy operation.
You can SHIFT-click to select multiple files or folders to restore.

If you have a problem copying files to a floppy disk

If you can’t save files on a floppy disk, then the disk is damaged or locked,
it’s too full to store more information, or the disk drive is not working
properly. These actions can help you identify the problem:
n Make sure that the tab on the back of the disk is in the unlocked

position (that is, make sure the square hole is closed).
n If an alert box reports that the disk is not initialized, and you know that

it has been initialized, eject the disk and carefully insert it again. If the
same message appears, the disk is probably damaged.
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n If an alert box reports that the disk is full, eject that disk and insert
another that has adequate space for your document, or remove
unneeded files from the disk.

n Check the disk for obvious damage to the plastic case or the sliding
metal shutter.

n Insert a different disk and try saving again. If you can’t save your files
on the second disk, the problem may be with the disk drive. Before
concluding that the disk drive is the problem, save your files on a disk in
a different drive, if you have one, and then restart the server. In the drive
that you think may be malfunctioning, insert a disk that you know is not
damaged, and try the same operation again. If you still can’t use that
drive to save files, see your authorized Apple service provider.

Ejecting a floppy disk

You can eject a floppy disk by using any of the following methods:
n Click the disk icon to select it, and choose Put Away from the File menu.

The icon disappears from the desktop and the disk is ejected.
n Drag the disk icon to the Trash. The disk icon disappears from the

desktop and the disk is ejected. (Dragging a disk to the Trash does not
erase the disk’s contents.)

n Click the disk icon to select it, and choose Eject Disk in the Special
menu. The disk’s icon remains on the desktop, but it’s dimmed.

You can use the first two methods to remove a hard disk icon from the
desktop (or to remove an icon for a disk that you’re connected to over a
network).

All three methods also work with CD-ROM discs.

If you have problems ejecting a floppy disk

If the drive won’t eject a floppy disk when you perform one of the eject
operations, either the signal to eject the disk is not reaching the computer
or the disk or drive is damaged.
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To eject a disk when standard operations don’t work:

1 To eject a disk in the internal drive, hold down the COMMAND (⌘ )  and SHIFT keys, and press
the number 1 key in the top row of the keyboard. To eject a disk in an external floppy disk drive
or the second internal drive, press COMMAND-SHIFT and the number 2 key at the same time.

2 If step 1 doesn’t work, shut down the server by choosing Shut Down from the Special menu. If
the disk isn’t ejected, hold down the mouse button while you turn the computer on again.

3 If step 2 doesn’t work, carefully insert the end of a large straightened paper clip into the small
hole to the right of the disk drive’s opening. Push gently until the disk is ejected. Do not use
excessive force.

4 If step 3 doesn’t work, take the computer or disk drive to your authorized Apple service
provider to have the disk removed. Never try to force or pry a disk from a drive.

Working with tape cassettes

You need to read this section only if your server includes the internal tape-
backup unit.

The internal 3.5-inch DDS-DC DAT drive and accompanying software can
perform full or partial backup and restore procedures for all of the data on
your hard disks. In addition, the drive automatically performs error
correction and data compression of the files that you back up and restore.
The error-correction feature helps ensure a high level of data integrity. The
data-compression feature allows more data to fit on a cassette than do
conventional backup mechanisms.

When you first supply power to your system, the tape drive performs a self-
test. Both tape-drive status lights on the front of the server flash amber
during the test. If for some reason the self-test fails, the light on the right
becomes solid amber.
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Your server comes with the Retrospect Remote software from Dantz, which
provides an easy-to-use interface for backing up and restoring data. You
can also use standard UNIX utilities such as tar or cpio to back up your
data. For more information about how to use the Retrospect Remote
software, see the Retrospect Remote documentation . For more information
about A/UX backup utilities, see Server Administration With A/UX 3.0.1.

Compatible tapes

Your internal DAT drive is compatible with MRS-quality DDS tape
cassettes. MRS (Media Recognition System) cassettes are the highest quality
digital data tape available. Your internal tape drive requires this level of
quality to perform backup operations successfully. See your authorized
Apple service provider for more MRS-quality DDS tape cassettes or their
compatible substitutes. Compatible cassettes are typically stamped “Digital
Data Storage.” If you use cassettes not approved by your authorized Apple
service provider, you void the warranty on your tape drive.
Note:  Some vendors of computer products may refer to DDS cassettes as
digital audio tape (DAT) cassettes. However, DAT cassettes have a different
mechanical specification from DDS cassettes. Certain DAT cassettes may
work with your tape drive; your authorized Apple service provider can tell
you which ones will work.

Tapes supplied with the server

Two cassettes are supplied with your Apple Workgroup Server 95. The first
is a blank DDS cassette for backup and restore operations. (The blank tape
included with your system can record up to eight gigabytes of data in
about three hours.) The second is a cleaning cassette; its operation is
discussed later in this chapter.
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Inserting tape cassettes

To use a cassette, you insert it into the tape slot in the front panel of the
server, as shown in this figure.

As you insert the cassette, the drive pulls it into place and performs a
loading sequence, which includes threading and rewinding the tape and
checking for error conditions. The loading procedure takes about 30
seconds. When the procedure is completed, a status light on the front of the
server glows a steady green. The other light alternates between green and
amber to let you know that the tape is being accepted by the drive. The
next section explains the status lights more fully.

Status lights

Located next to the tape drive opening are two lights that inform you of the
status of tape operations. The light on the left is the cassette light, and the
light on the right is the drive light. A solid green light indicates normal
operation; a solid amber light indicates a warning condition. Alternating,
flashing lights indicate activity between the tape drive and the SCSI bus.
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If the cassette light is solid amber, the cassette is write-protected. If the drive
light is solid amber, a fault condition exists. The following table lists all the
possible meanings of the status lights.

Cassette light Drive light
(left side) (right side) Meaning

Read/write states Flashing green Flashing green Cassette loading or 
unloading

Green Green Cassette loading/on line
Green Flashing green Cassette loaded/activity
Green Off Cassette loaded/off line

Write-protect states Flashing amber Green Cassette loading or 
unloading

Amber Green Cassette loaded/on line
Amber Flashing green Cassette loaded/activity
Amber Off Cassette loaded/off line

Error states Green Green/amber Media wear (caution)
Amber Amber High humidity/no 

termination on SCSI bus
Flashing amber Flashing amber Self-test (normal)
Flashing amber Amber Self-test (failure)

The caution signal

If your tape drive detects problems, it displays a caution signal. The cassette
light is solid green and the drive light switches between green and amber.
You can clear the caution signal by ejecting the cassette.

The caution signal may be caused by dirty tape-drive heads, so if this signal
appears, clean the heads and insert the tape again. (Head-cleaning
instructions are given in “Cleaning the Tape-Drive Heads,” later in this
section.) The caution signal may also indicate a worn-out tape. If the tape is
old or worn, you should replace the cassette. If you’re trying to restore
data from a worn tape and the caution signal appears, clean the tape-drive
heads, then try the restore operation again.
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Removing tape cassettes

You can remove a tape cassette at any time by pressing the eject button
located under the tape slot on the right side. You should not press the eject
button while the tape is in use. The documentation for Retrospect Remote
contains additional methods for ejecting cassettes when using the
Retrospect Remote software.
Note:  Standard UNIX eject commands will not release a cassette from the
tape drive.

Locking a cassette

You can lock a DDS cassette by sliding the tab on the back of the cassette
so that the hole is visible. Once a tape cassette is locked, data can be read
from the cassette but not written to it.

A solid amber cassette light indicates a locked cassette.

Avoiding high humidity

Whenever your tape drive detects water condensation, both status lights
glow solid amber. This warning signal cancels any commands in progress.
Furthermore, any commands that access the tape are rejected. The tape
drive then unthreads the tape to prevent tape and tape-head damage.

To minimize the chance of condensation, adhere to the environmental
requirements in Setting Up and Managing Your Server, and follow these
general cassette guidelines:
n Use tape cassettes at temperatures between 5° C (40° F) and 40° C

(113° F).
n If you expose the tape cassettes to temperatures outside the operating

limits, you can stabilize them by leaving them in the proper operating
temperature for a minimum of two hours.

Follow these guidelines to avoid temperature problems:
n Avoid exposing cassettes to severe temperature conditions. For example,

don’t store a cassette in a car in bright sunlight.
n Avoid transferring data to or from a tape cassette when the temperature

is changing by more than 10° F per hour (roughly 5° C per hour).
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Cleaning the tape-drive heads

The most common reason for the display of a caution signal on the front
panel is that the tape-drive heads are dirty. Although your tape drive has a
built-in roller for cleaning the heads during normal operation, you still
need to perform a separate cleaning step as part of preventive maintenance.

Your system comes with a cleaning cassette that you should use to clean the
tape-drive heads after every 25 hours of running time.

Use only a DDS cleaning cassette. When you insert the cleaning cassette
into the drive, the drive automatically loads it and cleans the heads. When
the cleaning process is completed, the drive automatically ejects the
cassette. Keep a record of how many times you use the cleaning cassette.
After 25 uses, replace it.

The interval at which you clean the tape drive depends on how often you
use it. In general, if you back up daily, you should clean the drive weekly.
If you back up weekly, you should clean the tape drive once a month.

For more information about using the cleaning cartridge, refer to the
instructions provided with the cleaning cartridge. For additional cleaning
cassettes, see your authorized Apple service provider.
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5 Working With TextEditor

This chapter describes how to use the TextEditor application program to create
and edit text files. It presents tutorials with step-by-step instructions that show
you how to accomplish simple writing and editing tasks.

This chapter discusses the following topics:
n starting and quitting the TextEditor program
n creating and saving documents
n editing and formatting text
n printing documents with TextEditor

If you are not familiar with Macintosh text-editing tools, you should read this
entire chapter. Otherwise, you can start with “Formatting and Other Features,”
and read other sections as needed.



Introduction to TextEditor
The TextEditor application program allows you to create and edit text files by
using the mouse and menu items in the traditional Macintosh manner.
TextEditor creates a file that contains only the text characters that you type at
your keyboard (including tab and return characters). This kind of file is called
a text-only file (or an ASCII text file), which means that the file does not
contain any formatting commands (such as font settings) that might confuse
other programs that try to use your file. A text-only file can be read by any
text-editing or word-processing program. Moreover, you can use TextEditor to
write programs or shell scripts, which should never contain hidden formatting
characters.
To preserve the text-only nature of its text files and still allow you certain
formatting choices, TextEditor gives you the option of saving the file’s
formatting information. It saves this information in a separate file called a
resource fork while it saves the text characters in a text-only file. These
formatting choices include adjusting the tab settings and choosing fonts. These
features are described later in this chapter.
The resource fork has the same filename as the text file, but it is preceded by a
percent sign (%).
Because TextEditor reads and writes text-only files, you can use it to work
with files created with any other text-only text editor. Thus, you can edit
MacWrite® files saved with the Text-Only option. When you choose the Open
item, TextEditor’s directory dialog box displays a list of all text files in the
folder, regardless of the program used to create the file.
A/UX also comes with a commonly used UNIX text editor called vi (which
stands for visual editor). This text editor is available on the A/UX CD-ROM;
however, it is not installed automatically. To learn how to install this editor,
consult Setting Up and Managing Your Server. TextEditor can read and edit
text files created with vi, and vice versa. For information about working with
vi, consult A/UX Text-Editing Tools in the A/UX 3.0 documentation suite.
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To work through the tutorial in this chapter, you must work in the
/users/start folder or log in to the start account. When the server is
shipped, the password for the start account is my.password. (For information
about the start account and logging in, see Chapter 2, “Getting Started With
A/UX 3.0.1.”)

Starting TextEditor
You can start TextEditor from the Finder by double-clicking the TextEditor
icon, an alias of the TextEditor icon, or a text-file icon.
This tutorial shows you how to start TextEditor by creating an alias of the
TextEditor icon and then double-clicking the alias.
TextEditor is located in the Applications folder.

To create a TextEditor alias:

1 Open the Applications folder and select the TextEditor icon.

2 Choose Make Alias from the File menu.

A new icon named “TextEditor alias” appears in the Applications window.
If an alert box appears, asking whether you want the alias icon to appear on the
desktop, click Yes.
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3 If no alert box appears, drag the TextEditor alias icon to the desktop.

You can now use the TextEditor alias icon without having to open folders.

TextEditor alias

Creating a document

To create a new document with the TextEditor alias icon:

nnnn Double-click the TextEditor alias icon.

A TextEditor window named Untitled appears. You can now begin to create
your text file.

Entering text

Begin by creating an office memo:

1 Type the following text.

Dear Phil:

The window on your screen should look like the one shown here.

66 Chapter 5 / Working With TextEditor



2 Press the RETURN key twice and type the following text:

I received your letter about the purchase of land for a
new office building.

You have probably typed past the edge of the window. Unlike many word
processors, TextEditor does not automatically move to the next line when you
type past the right edge of the window. This is a feature that programmers find
useful.

3 Move the I-beam pointer to where you want the line break to be; then click.

This action repositions the insertion point on the line. You can also move the
insertion point to the left by pressing and holding down the LEFT ARROW
key.

4 Press RETURN to move the rest of the sentence to the next line.

5 Move the insertion point to the end of the text, and press RETURN twice to start a new
paragraph.

6 Type the following text. Remember to press RETURN to go to the next line before you
reach the edge of the screen again.

It's true that the financial reports for the last quarter
are not in yet, but there is a general feeling that the
numbers look good. This might be the perfect time to
submit your plan.

7 Press RETURN twice to create a new paragraph, and then type the following text:

I don't want to rush you, but perhaps you should get ready
to take advantage of a real opportunity.
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Cutting and pasting text

The sentence that you typed in step 7 in the preceding section might look
better right before the material you typed in step 6. The two paragraphs would
then read as follows:
I don't want to rush you, but perhaps you should get ready
to take advantage of a real opportunity.

It's true that the financial reports for the last quarter
are not in yet, but there is a general feeling that the
numbers look good. This might be the perfect time to
submit your plan.

To rearrange the text:

1 Place the I-beam just before the first letter of the sentence beginning I don’t want.

2 Hold down the mouse button and drag the I-beam past the period after the words real
opportunity. Release the mouse button.

The text is now selected.

You can perform various operations with a block of selected text. In this case,
you are going to cut and paste the text.
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3 Choose Cut from the Edit menu.

The selected text disappears. The passage that you cut is saved on the
Clipboard. (If you choose the Show Clipboard item from the Edit menu, a
window appears, showing the selected text saved in the Clipboard.)

4 Move the I-beam pointer to the end of the first paragraph and click. Then press RETURN
twice to create a new paragraph.

This places the insertion point where you are going to paste the text that you
just cut.

5 Choose Paste from the Edit menu.

The selected text appears in its new location.

The selected text remains on the Clipboard until you replace it with another
block of selected text. If you wanted to, you could paste copies of it in any
number of other places in the document.

To save this memo, go to the next section.
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Saving a new document

If you wish to keep a file you have created, you must save the file and give it a
name.

To save the memo:

1 Display the File menu.

Point to the menu name, and press and hold down the mouse button. The first
three of the following four items allow you to save a file:
n Save
n Save As
n Save a Copy
n Revert to Saved
(The actions of all four commands are described at the end of this exercise,
after step 5.)

2 Choose Save As.

A Save As dialog box appears, asking you to specify a name for the file.

3 Type the name memo2 in the “Save document as” field.
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4 Be sure that the Save Text Only button is selected.

If you had used any of the formatting options (described later in this chapter),
you could have saved them in a separate file by selecting Save Format Info.
The document would then be saved in two files, memo2 and %memo2. The
second of these, the resource fork, would preserve the formatting information.
However, since you haven’t used the formatting options, it isn’t necessary to
create an extra file.

5 Click Save.

The memo is saved as a file with the filename memo2.

Here is a summary of the four File menu items that deal with changes to a file:
Save: If the file in the active window already has a filename, the Save item
automatically saves it under its current name, without closing it. The original
version of the file of that name is overwritten in the process. This menu item is
dimmed (and therefore cannot be used) if the file hasn’t been modified since it
was last saved.
Save As: In addition to using this menu item to name a new file (as you have
just done), you can use it while working on a file that already has a name. This
lets you save an edited file under a new name, leaving the original intact. The
file that you originally opened remains unchanged, just as it was when last
saved.
Save a Copy: This menu item saves the file, in its current state, under a new
filename. You can then continue editing the original file.
Revert to Saved: Use the Revert to Saved item to throw away any changes you
have made since you last saved the document. This item is dimmed if the
document has not been modified since it was last saved.
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Editing an existing document

The tutorials in this section show how to edit or rewrite a document that you
have created.

Opening a file

If TextEditor is running, you can open a file for editing by choosing Open
from the File menu. This item allows you to open any text-only file, regardless
of what application was used to create the file.

To open a document:

1 Choose Open from the File menu.

A directory dialog box appears.

2 Double-click the name memo1.

The document appears in a window and is ready for editing.

Alternately, to open a document:

nnnn Double-click the icon of the file to be edited.

TextEditor starts running and the file that you clicked is opened for editing.
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To find the file to use with this tutorial:

1 Open the start folder. This folder is contained in the users folder on the slash (/)
hard disk.

If you have not quit TextEditor since working through the last tutorial, you are
already working in the start folder.

2 Double-click the memo1 file icon.

The memo1 file is opened and the document is displayed. Now you can alter
this document and save it under a new name.

Opening read-only files

You can open a file for which you have read permission but not write
permission. To do this, be sure that you have selected the “Open read only”
checkbox at the bottom of the Open dialog box. If you open a document for
which you do not have write permission, an icon indicating that you don’t
have write permission appears at the lower-left corner of the window. You can
read the document, but you cannot change it.

Icon representing no write permission
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Deleting and rewriting text

Examine the beginning of memo1 on your screen. Notice the sentence that
begins halfway through the second line of the first paragraph of memo1
(“Every salesperson who’s . . .”).

To delete or alter text:

1 Select the phrase Every salesperson who's.

Drag the I-beam across the phrase to just past the word who's; then release
the mouse button.

2 With the phrase selected, type the following text:

The salespeople who have

The selected text disappears as soon as you begin to type. This is the fastest
way to replace a block of text. It saves you the trouble of first deleting text and
then typing the new text.

3 Select the letter s at the end of the word knows in the next line; then press DELETE to
delete the letter.

Copying and pasting between documents

Next, you will add the entire memo you have just edited to the bottom of a
business letter. The letter is in the start folder, in the file letter1.

To select the material to be copied:

1 With the window that contains memo1 displayed, choose Select All from the Edit menu.

This menu item selects the entire document.

2 Choose Copy from the Edit menu.

The selected text (in this case, the entire memo) is saved on the Clipboard.
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To open the document to which you’ll copy the text:

1 Choose Open from the File menu.

This displays a list of all the files in the start folder.

2 Double-click letter1.

3 Scroll to the end of the letter by using the scroll bar at the right edge of the window.

4 Place the insertion point at the end of the signature and press RETURN twice to start a
new paragraph; then choose Shift Left from the Edit menu to move the insertion point to
the left margin.

5 Type the following postscript:

PS: To give you a clear idea of our level of commitment to
customer support, I'm appending a memo I recently sent to
my staff.

6 Press RETURN twice to skip two lines; then choose Paste from the Edit menu.

All of the copied text appears at the insertion point.

Normally you would now save the changed file, but because other users use
these tutorials, don’t save the changes.

To close a document without saving your changes:

1 Choose Revert to Saved from the File menu.

The Revert to Saved item causes all changes to the document to be removed.
An alert box appears.

2 Click OK.

The alert box disappears.
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3 Click the close box of the letter1 window (the small square at the upper-left corner of
the window).

The window that contains memo1 is still displayed.

4 Close the memo1 window without saving the changes by clicking its close box or by
choosing Close from the File menu.

Finding and changing text

One of the most important time-saving features of a text editor is its ability to
search through a document for a specific word, phrase, or string of characters
and to change it automatically.

Finding text

TextEditor lets you find a word, phrase, or character string.

To find a specific block of text:

1 Open the start folder and double-click the memo1 icon to open the document.

2 Choose Find from the Find menu.

A dialog box like this one appears.
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3 Click the Entire Word button and the Case Sensitive checkbox.

You click the Entire Word button to find the item only when it is an
independent word (that is, when it is not part of another word). You would
click Literal instead of Entire Word if you wanted to find all instances of a
string of characters, even when the string is embedded in another word. Thus,
if you clicked Literal and searched for the word it, the system would find bit,
split, flit, and so on.
You select the Case Sensitive checkbox to tell the system to search only for
words with the same uppercase and lowercase letters as the word you indicate.

4 Type good in the “Find what string?” text box.

5 Click the Find button.

The word good in the last line of the document becomes highlighted.
The dialog box displayed by the Find command gives you the following
options as well:
Search Backwards: Searches backward from the current selection to the
beginning of the file. (Normally, the search moves forward and stops at the
end of the file.)
Wrap-Around Search: Searches forward from the location of the insertion
point to the end of the file, then starts again at the beginning of the file and
continues the search up to the starting insertion-point position.
Note: You can reverse the direction of a search operation by pressing SHIFT as
you select the menu item or by pressing SHIFT while you click OK. For
example, if you are in the middle of a file and you want to find a string that
occurs earlier in the document, hold down the SHIFT key while you click Find.
The search then proceeds backward through the first part of the file. The
direction is changed for the current search only.
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Replacing text

TextEditor lets you find a word, phrase, or text string and replace it
automatically with a different word, phrase, or text string.

To replace a text string:

1 Open the start folder (in the users folder), and double-click to open memo1.

2 Choose Replace from the Find menu.

A dialog box like this one appears.

3 Select Entire Word and Case Sensitive.

You click the Entire Word button to find the item only when it is an
independent word (that is, when it is not part of another word). You would
click Literal instead of Entire Word if you wanted to find all instances of a
string of characters even when the string is embedded in another word. Thus,
if you clicked Literal and searched for the word it, the system would find bit,
split, flit, and so on.
You select the Case Sensitive checkbox to tell the system to search only for
words with the same uppercase and lowercase letters as the word you indicate.

4 Type good in the “Find what string?” text  box.

5 Type excellent in the field labeled “Replace with what string?”

6 Click Replace (or press RETURN).

The word good is replaced by the word excellent.
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The dialog box displayed by the Replace command gives you the following
options as well:

Replace All: Changes all occurrences of the word good (or whatever string
you indicate) automatically.

Cancel: Removes the dialog box. No further action is taken.

Search Backwards: Searches backward from the current selection to the
beginning of the file. (Normally, the search moves forward and stops at the
end of the file.)

Wrap-Around Search: Searches forward from the location of the insertion
point to the end of the file, then starts again at the beginning of the file and
continues the search up to the starting insertion-point position.

Formatting and other features

If you use any formatting features, you can save the formatting information by
selecting Save Formatting Information in the Save As dialog box. This causes
an extra file, called the resource fork, to be saved. The resource fork contains
the formatting information.

The Edit menu and the Window menu make the following features available to
you:
n selecting fonts
n selecting tab settings
n automatically aligning text with the previous line (Auto Indent)
n showing invisible characters, such as tabs, spaces, and returns
n shifting a block of text left or right by one tab stop
n aligning selected text with the top line of the selection
n arranging multiple windows to be stacked one over the other or tiled

(placed alongside one another)
n marking a place in the file

The following sections explain how to use these features.
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Formatting text

You can use the Format item to change the font and size of text, set tabs,
automatically align text, and display or hide “invisible” characters.

To use the Format item:

1 Choose Format from the Edit menu.

A dialog box like this one appears.

Selecting font and size
Select the desired font and size.

Automatically aligning text
Click this checkbox to select Auto
Indent. You can click it again to de-
select it, thus turning off Auto Indent.

Selecting tab settings
Type the desired number of spaces
in this text box.

Showing invisible characters
Click this checkbox to display spaces, tabs, returns,
and control characters. You can click it again to
deselect it, thus hiding the “invisible” characters.

2 When you have finished formatting the text, click OK.

Shifting a block of text left or right

To shift an entire block of text one tab stop to the left or to the right:

1 Select the block of text.

2 Choose Shift Left (or Shift Right) from the Edit menu.
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Arranging multiple windows

If you are editing several documents at the same time, you have a choice of
stacking or tiling the windows.

To rearrange windows on the screen:

1 Choose Open from the File menu.

2 Double-click the memo1 file in the start folder.

The document appears in a window and is ready for editing.

3 Choose Open from the File menu again.

4 Double-click the letter1 file.

The windows are stacked by default, as shown here.
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5 Choose Tile Windows from the Window menu.

The windows are laid out alongside one another. Notice that the sizes of the
windows change so that they can fit on the screen.

Tiling makes it easy to work with several windows at once. To use this feature
most effectively, however, it’s best to have a large monitor. On a small
monitor, the windows might become too small.

IMPORTANT  When a window becomes too small because of tiling, the text in
the window becomes too small to work with. To make the text easier to work
with, you must reopen the file in a larger window.
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6 Choose Stack Windows from the Window menu.

The windows change to a stacked layout.

Marking a place in the file

If you need to return periodically to specific locations in a long or complex
document, you can place invisible, named markers at those points. You can
then jump instantly to any of the marked places in the document. This saves
you the time and trouble of having to scroll through the document to find those
places.

The tutorial in this section teaches you how to mark and unmark a document.
The tutorial uses letter1 (in the start folder) as a sample document,
although markers are most useful in long, complex files.
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To place two named markers in letter1:

1 Highlight the word We at the beginning of the second paragraph.

2 Choose Mark from the Mark menu.

A dialog box like this one appears.

The text box contains the highlighted word, which you will use as the name of
the marker. If you wanted to give the marker a different name, you would type
the name in the text box.
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3 Click OK.

The first marker, We, is placed at the beginning of the sentence. The dialog
box disappears.

4 Click at the beginning of the third paragraph of letter1.
The insertion point appears there.

5 Choose Mark from the Mark menu again.

6 Type the numeral 2.

That is the name of the second marker.

7 Click OK.

8 Now display the Mark menu.

The menu now contains a list of the markers that you have placed in the
document.

9 Choose We from the Mark menu.

The insertion point moves to the We marker. If you choose 2, the insertion
point moves to the third paragraph.
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To remove these markers:

1 Choose Unmark from the Mark menu.

A dialog box like this one appears.

2 Select the name of the marker that you want to remove (in this case, 2).

3 Click Delete.

If you look at the Mark menu, you can see that the marker you have deleted is
no longer on the list.

4 Repeat steps 1 through 3 to delete the We marker.

Printing

TextEditor allows you to print either an entire document or a selection from a
document. Be sure that your computer is properly connected to a printer and
that you use the Chooser (in the Apple menu) to choose a printer. For
information on printer connections, see Chapter 6, “Printing From the
Desktop.”

Printing an entire document

To print an entire document:

1 Open the document in TextEditor.
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2 Choose Print Window from the File menu.

The print-file dialog box appears.

3 Click Print to begin printing.

Printing a selected part of a document

To print a block of text:

1 Place the insertion point at the beginning of the text to be selected.

2 Drag the I-beam pointer to the end of the desired selection and release the mouse button.

The selected text is highlighted.

3 Choose Print Selection from the File menu.

The print-file dialog box appears.

4 Click Print to start printing.
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Quitting TextEditor

To quit TextEditor:

1 Choose Quit from the File menu.

If you have made changes to a file, an alert box appears, asking whether you
want to save those changes.

2 Click Save or Don’t Save, or click Cancel if you change your mind about quitting.

To leave the tutorial files unchanged for later use, click Don’t Save.
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6 Printing From the Desktop

This chapter discusses printing with the Macintosh interface. It covers the
following topics:
n how printers may be connected to your system
n how to choose a printer
n Macintosh printing techniques

For information about printing using UNIX commands, see Server
Administration With A/UX 3.0.1.



Printer connections

Before you can print a document, you must have a printer properly connected
to your system or to the network. See Setting Up and Managing Your Server
for information on connecting a printer to the computer. For basic information
on connecting a printer to a network, see Server Administration With
A/UX 3.0.1.

To print from Macintosh applications, you can reach a printer in two basic
ways:
n Use a printer that is connected directly to a printer port on the computer.

   

Printer connected directly to server.

 

Text documents from CommandShell
or Macintosh documents

A/UX does not support the LaserWriter SC or the Personal LaserWriter SC
printer.
Note:  A LaserWriter IISC printer that is directly connected to the SCSI port
won’t work with the Apple Workgroup Server 95.
n Use a printer that is connected to an AppleTalk network through the printer

port to a LocalTalk cable system or through the built-in Ethernet card to an
Ethernet cable system.
Any computer on the network can send files created with a text editor or a
Macintosh program to the printer. The files are printed in the order in which
they are received.
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Printer connected by means of an AppleTalk network.

Printer with Ethernet connectors
connected by means of
an AppleTalk network.

AppleTalk
router

Text documents from 
CommandShell or 
Macintosh documents.

 LocalTalk 
connection

EtherTalk 
connections to router
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People who use CommandShell and UNIX commands for printing use the
Transmission Control Protocol/Internet Protocol (TCP/IP) over the type of
network shown in the preceding figure. They can print on the same printer
used by Macintosh programs. TCP/IP and AppleTalk coexist on the same
network cable.

CommandShell users can also print on a printer that is directly connected to
another workstation on the TCP/IP network as long as the computer is another
A/UX system or a computer that supports the printer daemon, lpd. For
detailed information about printing from CommandShell, see Server
Administration With A/UX 3.0.1.

Choosing a printer

Before you can print a file in the Apple Workgroup Server 95 environment,
you must specify which printer you want to use. Use the Chooser (in the Apple
menu) to select a printer. Some programs direct you to choose Page Setup after
using the Chooser.  For further information, see the guide that came with the
program you are using.

You can choose any printer that is connected to your computer or your
network through AppleTalk software, LocalTalk (or LocalTalk-compatible)
cables, and EtherTalk cables.

To choose a printer that is connected directly to your computer or is on your
AppleTalk network:
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1 Choose Chooser from the Apple menu.

The Chooser window opens. An icon appears in the upper-left part of the
window, representing each of the printer types for which you have printer
resources installed in the currently active System file. The AppleShare icon
appears if you have access to one or more file servers.

List of available printers

Background printing
option; when on, allows
you to continue working
while your files print

Printer and server icons

AppleTalk zones
available 
(if on a network)

2 Click the icon representing the type of printer you want to use.

3 Select the appropriate zone from the AppleTalk Zones list, if applicable.

4 Select the appropriate printer name in the LaserWriter printer list.

5 Click the close box.

The Chooser window closes; you are ready to print.
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Using Macintosh printing techniques

You can use the Finder to print a Macintosh file (for example, one created by a
Macintosh program). You must have chosen a printer as described in the
previous section.

To print a Macintosh file from the Finder:

1 Select the document you want to print by clicking its icon.

2 Choose Print from the File menu.

The print-file dialog box appears. Change settings in the dialog box as
necessary.

3 Click Print.

You can also print from within a Macintosh program. Consult the manual that
came with the program for more information on printing.

The PrintMonitor program

The PrintMonitor program keeps track of the status of your printing operation.
If the system has messages for you regarding a file that you are trying to
print—for example, that the printer has run out of paper—a flashing
PrintMonitor icon appears over the Application menu icon. You can read the
message and respond as necessary by opening the Application menu and
choosing PrintMonitor.
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Transferring fonts to a LaserWriter printer

If you’re using a LaserWriter printer that’s equipped to handle the
PostScriptTM programming language and you want to print using PostScript
outline fonts that are not built into your printer, you can transfer, or download,
outline fonts from your System Folder to the printer. ( The PostScript
programming language describes the characters, symbols, and images
appearing on each page of a document.) Downloading fonts saves you printing
time if you plan to print a batch of documents that use those fonts.

When you download a font, it’s stored in the printer’s memory or on a hard
disk attached to the printer. You can download as many outline fonts as the
printer’s memory and hard-disk space allow.

You download a font by using the LaserWriter Font Utility, which is supplied
on the system software disks.

To transfer fonts to a printer:

1 Locate and open the LaserWriter Font Utility icon.

2 Choose Display Available Fonts from the File menu.

A dialog box appears, showing you what fonts are already loaded into the
printer.

3 Choose Download Fonts from the File menu to add new fonts.

A dialog box like this one appears.
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4 If the font that you want to download is not listed, click the Add button to add fonts to the
list.

A directory dialog box appears. You use this dialog box to locate the fonts you
want.

5 Click the name of the font you want, then click Add.

You can press the SHIFT key while you click to select more than one font.

6 When you’ve added all the fonts you want to download, click Done.

The directory dialog box disappears, and the fonts you added are listed in the
Font Utility dialog box.

7 Click the Download button to send all the fonts in the list to the printer or its hard disk.

A status box appears. The status box contains a Cancel button that you can
click to stop the process.

8 Click OK when the status box reports the results of downloading.

9 Choose Quit from the File menu.
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7 Customizing the Finder Environment

You can customize your working environment to suit your needs and
preferences. This chapter tells you how to perform a number of alterations to
your environment, including
n installing items and removing items from the System Folder
n arranging items so that they are opened at startup or available through the

Apple menu
n adding and removing fonts
n adjusting the way your mouse and keyboard work
n changing your computer’s alert sound
n altering your screen’s appearance
n setting up more than one monitor
n installing application programs



Installing files in the System Folder

Certain types of programs and other files need to be installed in the System
Folder so that your server can use them as part of the system software. Your
server has three System Folders that control different aspects of operation.
The Startup System Folder controls the startup process, the Login System
Folder determines your environment when you log in, and the System Folder
controls your environment while you are logged in and using your account.
You only need to make changes to the System Folder, and you should not
alter the contents of the Startup System Folder or the Login System Folder.
Only one System Folder in A/UX is active at a time. It is the one with a
picture of a computer on its folder icon. All three System Folders are found in
the sys folder, which is located in the mac folder.

The types of files you can install in the System Folder include
n system extensions and control panels (also called INITs and cDEVs)
n files of preferences for application programs
n drivers for printers, scanners, and other devices
n sounds
n fonts

Sometimes these files are installed by means of an installer program that
comes with the files. Check the instructions that came with the files for any
specific installation procedures.

To install a file that does not require special treatment:

nnnn Drag the file’s icon to the System Folder icon (not the System Folder window).

The file is stored in a specific folder inside the System Folder. When you
drag a file’s icon to the System Folder icon, the Finder recognizes which type
of file it is and stores it in the appropriate folder.
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If you drag one of these files to the System Folder window rather than to the
System Folder icon, the file is not stored in the appropriate folder
automatically. Items that you want to put in the Apple Menu Items folder or
the Startup Items folder inside the System Folder need to be dragged to that
specific folder. (See the instructions later in this chapter for installing Apple
menu items and for specifying the files you want opened at startup.)

Removing files from the System Folder

Depending on the external devices you use, whether you’re part of a network,
and how you use your server, you can remove the following types of files
from your System Folder if you want to conserve space:
n Apple menu items that you don’t use. (You need the control panels, but

you may not need the Calculator or the Puzzle, for example.)
n Extra fonts, sounds, or keyboard files that you have installed.

To remove a file from the System Folder:

nnnn Drag its icon out of the System Folder or out of any folder inside of the System Folder.

If you drag the files to the Trash, but think you might have future use for
them, be sure you have backup copies of the files on floppy disks.

Specifying which items you want opened at startup

To have a file (a program or a document) open automatically when you start
up your server:

 1 Open the System Folder.

 2 Drag the file’s icon or its alias to the Startup Items folder.

Any programs or documents (or their aliases) that you put in the Startup
Items folder are opened when you start up your server. You can have as many
files open automatically as your computer’s memory allows.

If you no longer want a file to open automatically when you start up your
server, remove the file’s icon (or its alias) from the Startup Items folder.
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Installing an item in the Apple menu

To have a program, document, or other item appear in the Apple menu:

1 Open the System Folder.

2 Drag the item’s icon or its alias to the Apple Menu Items folder.

You remove an item from the Apple menu by opening the Apple Menu Items
folder and dragging the item’s icon (or its alias) out of the folder.

Using fonts

A font is a collection of letters, numbers, and symbols in a distinctive
typographic design. Several fonts are installed in the System file with your
Apple Workgroup Server 95. You can install additional fonts and remove
fonts. Additional fonts are supplied with the system software. Fonts are also
available from independent manufacturers, user groups, and computer
bulletin board services.

Outline fonts and bitmapped fonts

Your computer uses two types of fonts: outline and bitmapped. Both types of
fonts are installed in the System file in the System Folder.

Outline fonts (also called scalable or variable-size fonts) describe each letter,
number, or symbol as a mathematical formula that defines the character’s
shape and adjusts itself to make the character’s size larger or smaller. You
need, therefore, only a single outline font in a particular typeface (such as
Times®) to be able to print or display that typeface in different sizes.

The outline fonts supplied with your Apple Workgroup Server 95 are called
TrueType fonts.

By contrast, bitmapped fonts (also called fixed-size fonts) describe each
character as a grid of black and white dots (called a bitmap), which is a
rendering of the character’s shape in a specific size.

Your computer needs a separate bitmapped font of a typeface in each size it
prints or displays, such as 12-point Times or 10-point Helvetica®.
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Installing fonts

To install a font:

1 Quit all programs that are open.

Pull down the Application menu to make sure that the Finder is the only open
program. Choose any other open program from the Application menu, and
then choose Quit from the File menu.

2 Locate the icon of the font that you want to install, and drag it to the System Folder icon
(not the System Folder window).

To select multiple icons, hold down the SHIFT key while you click the icon
for each font.
A dialog box appears, letting you know that the fonts will be stored in the
System file, where they belong.

3 Click OK.

Removing fonts

To remove a font:

1 Open the System Folder.

2 Locate the System file icon and open it.

3 Locate the icon of the font that you want to remove, and drag it out of the System
window and out of the System Folder window. (SHIFT-click to select more than one
icon.)

4 Close the System window and the System Folder window.

Setting the time, date, and alarm

Your computer has a clock that keeps track of the time and date. (A battery
keeps it running when the computer is turned off.) An alarm clock feature is
also available.
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Changing the time and date

Many programs rely on the clock to automatically enter times and dates in
documents that you create or print, so at some point you will need to set the
clock to the current time and date.

To change the time and date:

1 Choose Control Panels from the Apple menu.

The Control Panels window opens, showing you the different control panels
that are installed in your System Folder.

2 Open the General Controls panel.

The time and date adjustments are in the lower-right corner of the General
Controls window.

3 If you want to change the way the time is displayed (12-hour or 24-hour), click the
appropriate button.

The 12-hour format uses A.M. and P.M.; the 24-hour format does not. (1:30
P.M. is displayed as 13:30.)

4 Click the hours, minutes, or seconds in the time display to select them.

Up and down arrows appear to the right of the time display.

5 Click the up or down arrow repeatedly until the current hour, minute, or second
appears.

6 Repeat steps 4 and 5 as necessary to set the entire time display.
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7 In the date display, click the month, day, or year to select it.

Up and down arrows appear to the right of the date display.

8 Click the up or down arrow repeatedly until the current month, day, or year appears.

9 Repeat steps 7 and 8 as necessary to set the entire date display.

10 Close the General Controls window.

You can also set the time and date in the Alarm Clock, which you open by
choosing Alarm Clock from the Apple menu.

Setting a time for the Alarm Clock to go off

You can set the Alarm Clock to alert you when it’s time for an appointment
or a meeting.

To set the Alarm Clock:

1 Choose Alarm Clock from the Apple menu.

The Alarm Clock opens.

2 Click the upward-pointing lever near the upper-right corner to expand the Alarm Clock.

The lever points downward, and the Alarm Clock expands to its full size.

3 Click the Alarm Clock icon in the lower-right corner to select it.

The Alarm Clock icon is highlighted when you select it. The time that
appears in the middle row is the current Alarm Clock setting.
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4 Click the hours, minutes, or seconds in the Alarm Clock setting to select them.

Up and down arrows appear to the right of the time display.

5 Click the up or down arrow repeatedly until the hour, minute, or second at which you
want the alarm to go off appears.

6 Repeat steps 4 and 5 as necessary.

7 Click the button to the left of the Alarm Clock setting to turn on the alarm.

When you click, the button moves up, and the Alarm Clock icon changes to
indicate that the alarm is turned on. (Clicking again turns the alarm off.)

8 Click the close box to close the Alarm Clock.

The alarm will not go off unless you close the Alarm Clock, click the lever to
make the Alarm Clock smaller, click elsewhere in the controls, or make
another window active.

Turning off the alarm

When the system clock reaches the time set for the alarm, the alert sound
plays twice (or the menu bar flashes once, if the speaker volume is set to
zero) and an alarm clock icon blinks over the Apple icon at the left end of the
menu bar.

To turn off the alarm:

1 Choose Alarm Clock from the Apple menu.

2 Click the lever to expand the Alarm Clock.

3 Click the button to the left of the Alarm Clock setting so that the button moves down.

4 Close the Alarm Clock.
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Adjusting the way the mouse works

You can adjust two aspects of mouse operation in the Mouse control panel:
tracking, which is the relation between mouse movement on your desk and
pointer movement on the screen, and the rate of double-clicking recognition.

To adjust mouse tracking:

1 Choose Control Panels from the Apple menu.

The Control Panels window appears.

2 Open the Mouse control panel.

The Mouse control panel window appears.

3 Click the tracking speed that you want to specify for the mouse pointer.

If you click Fast, the pointer moves more than twice as fast as you move the
mouse. The Very Slow option is useful for drawing with the mouse or a
graphics tablet, because the pointer moves at a constant speed relative to
mouse movement.
Your selection takes effect immediately and remains in effect until you select
a different tracking option.

4 Close the Mouse control panel.
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To adjust double-clicking speed:

1 Open the Mouse control panel.

2 Click the double-clicking speed you want to use.

You may have to adjust the double-clicking speed if your computer often
misinterprets two clicks as a double click, or a double click as two single
clicks.
Your selection remains in effect until you select a different double-clicking
speed.

3 Close the Mouse control panel.

Adjusting the way the keyboard works

This section tells you how to customize various keyboard functions,
including  the character repeat rate and control of the pointer with the
keyboard.

Character repeat and layout

You can adjust the rate at which a character repeats when you hold down its
key, as well as the length of the delay before the character begins repeating.
You can also change the layout—that is, the arrangement of the keys on the
keyboard.

To adjust the rate at which a key repeats when it is held down:

1 Choose Control Panels from the Apple menu.

The Control Panels window opens.
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2 Open the Keyboard control panel.

3 Click the button for the rate you want.

The buttons for this option are in the upper-left corner of the control panel.
After you close the control panel, your selection remains in effect until you
change it.

To adjust the delay before keys repeat:

1 Open the Keyboard control panel.

2 Click the button for the delay you want.

If the keys repeat when you don’t want them to, adjust the keyboard’s
sensitivity to your touch by setting a longer delay before a character begins
repeating. (If you click the Off button, the keys don’t repeat at all.)
After you close the control panel, your selection remains in effect until you
change it.
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To change the keyboard layout:

1 Click the name of the keyboard layout you want to use.

Depending on the country in which you bought your server, you may have a
choice of more than one keyboard layout. (Additional keyboard layouts are
available from various sources, and you install them in the System Folder as
you would fonts or sounds.)
After you close the control panel, your selection remains in effect until you
change it.

2 Close the Keyboard control panel.

Controlling the pointer from the keyboard

With a software feature called Mouse Keys, you can use the numeric keypad
on the right side of the keyboard (instead of the mouse) to control the
movement of the pointer on the screen.

n To turn on Mouse Keys, press COMMAND-SHIFT-CLEAR. (The CLEAR key is on the
numeric keypad.)

n To turn off Mouse Keys, press CLEAR.

With Mouse Keys turned on, you can click, drag, and perform all of the usual
mouse actions from the numeric keypad. The 5 key serves as the mouse
button: Press once to click; press twice to double-click. The 0 key locks the
mouse button down for dragging. Pressing the decimal point key (to the right
of 0) or the 5 key unlocks the mouse button.

You can adjust the speed at which the pointer moves on the screen and the
length of the delay before the pointer starts moving when you press a mouse
key. You make these adjustments in the Easy Access control panel. (Choose
Control Panels from the Apple menu, and open Easy Access.)

Setting the alert sound

Many programs cause the computer to make a sound, called the alert sound,
when your attention is required or when you’re giving a command or
attempting an action that the computer cannot recognize or perform at that
time.
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Changing the sound and volume

You can choose among several sounds that you want the computer to make.
You can also set the sound’s volume.

To chose an alert sound:

1 Choose Control Panels from the Apple menu.

2 Open the Sound control panel.

The Sound control panel opens. The alert sound that your computer is
currently using is already selected.

3 Click the name of the alert sound that you want the computer to use.

When you select a sound, the computer plays the sound at the current volume
setting.

4 Drag the slide control up or down to set the volume level.

If you want to be alerted silently:  Drag the slide control to 0. The computer
will not emit an alert sound; instead, the menu bar will flash.

5 Close the Sound control panel.
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Installing a sound

The Apple Workgroup Server 95 comes with a standard set of alert sounds.
You can obtain additional sounds from independent manufacturers, user
groups, and computer bulletin board services.

To install a sound:

n Drag its icon to the System Folder icon (not the System Folder window).

The sound is automatically installed in the System file, where it belongs.

Once you add a sound to the System file, it is listed in the Sound control
panel.

Recording sounds

Your Apple Workgroup Server 95 can accept and process sound input. These
computers come with a sound input port, to which you can connect either a
microphone (which must be purchased separately) or a phono jack adapter (to
record sounds from another audio source, such as a compact disc or an audio
cassette).

You can record a sound and add it to your available alert sounds in the Sound
control panel. Make sure you’ve connected a microphone to your computer as
described in the setup book that came with your microphone.

To record an alert sound:

1 Choose Control Panels from the Apple menu.

2 Open the Sound control panel.

The Sound control panel appears. Icons representing the available sound
input devices appear near the bottom of the window.

3 Click the icon that represents the sound input device you want to use.

4 Click the Add button.

A dialog box that looks like the controls of a tape recorder appears.
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5 To record your new sound, click the Record button.

Recording begins immediately; you have ten seconds to record your sound.
There is no recording volume control.

6 Click Stop to stop recording.

7 To listen to the sound you recorded, click Play.

8 To save the sound you recorded, click Save.

A dialog box appears in which you name your new sound.

9 Type a name for the sound.

10 Click OK.

The new sound appears in the Alert Sounds list in the Sound control panel.

When you’ve finished recording new sounds, close the Sound control panel.

Removing a sound

IMPORTANT  Make sure you have backup copies of the sounds before you
remove them from your system.

To remove sounds from the Sound control panel:

1 Choose Control Panels from the Apple menu.

2 Open the Sound control panel.

3 Click the name of the sound you want to remove.

Make sure you select the correct sound. You cannot undo the next step.

4 Click the Remove button and then click OK.

5 Close the Sound control panel.

You can also remove a sound by selecting it and then choosing Cut or Clear
from the Edit menu or by dragging its icon out of the System file and out of
the System Folder.
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Changing the screen’s appearance

You can customize the appearance of your screen by changing the desktop
pattern, altering the blinking of menu items and the insertion point, changing
the appearance of windows and icons, and using different colors and shades.
This section tells you how to make these modifications.

Changing the desktop pattern

You use the General Controls panel to change the pattern that appears on the
desktop.

To change the desktop pattern:

1 Choose Control Panels from the Apple menu.

2 Open the General Controls panel.

You can choose from a variety of patterns or you can create your own design
by editing one of the patterns supplied. If your computer can display colors or
shades of gray, you can also select your own colors to use in the pattern.
n To display the available patterns, click either of the small triangles at the

top of the miniature desktop in the Desktop Pattern area.
The pattern changes each time you click.

n To see how a new pattern looks, click the miniature desktop.
The new pattern appears on the desktop and remains in effect until you
change it.
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n To edit a pattern, click in the square to the left of the miniature desktop.
Each dot in the square changes color when you click it. Your changes are
displayed in the miniature desktop.

n To use another color, click the color in the color bar (below the words
Desktop Pattern) to select it, then click the dots you want to change in the
square to the left of the miniature desktop.
To make a new color available in the color bar, double-click a color in the
color bar and then choose a new color from the color wheel in the dialog
box that appears. For more information about changing colors, see the
sections “Changing the Highlight Color” and “Changing the Color of
Windows” later in this chapter.

3 When you’ve finished creating your new pattern, click in the miniature desktop to
display the pattern on your desktop.

4 Double-click the miniature desktop to save the new pattern.

Otherwise, it is lost when you display another pattern in the miniature
desktop.

Adjusting the blinking of a menu item

You can change the number of times a menu item blinks when it’s chosen.

To adjust menu blinking:

1 Choose Control Panels from the Apple menu.

2 Open the General Controls panel.

You adjust the blinking of a menu item with the controls in the lower-left
corner.

3 Click the button for the number of times you want the menu item to blink.

Clicking the Off button prevents a menu item from blinking.
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The option you selected remains in effect until you change it.

Adjusting the blinking of the insertion point

You can adjust how quickly the insertion point blinks. (The insertion point
indicates where any text you type appears.)

To adjust the blinking of the insertion point:

1 Choose Control Panels from the Apple menu.

2 Open the General Controls panel.

You adjust the blinking of the insertion point with the controls in the upper-
right corner.

3 Click the button for the blinking rate you want.

When you click, the insertion point in the control panel shows the rate of
blinking you selected.
The option you selected remains in effect until you change it.

Changing the items in the Label menu

You can change the labels (and colors, if your monitor displays colors or
shades of gray) available in the Label menu. You make these changes in the
Labels control panel.
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To change a label in the Label menu:

n Drag across the text to select it, and then type your new label.

To change a color in the label menu:

1 Click the color you want to change in the Label control panel.

The color wheel dialog box appears.

2 Click a color on the color wheel to select it.

The new color is displayed in the upper half of the color square. The current
color remains in the lower half of the square for comparison.

3 To experiment with other colors or shades, drag the pointer around the wheel, or click
at another point on the wheel.

The new color is displayed in the upper half of the color square as you drag
or click.

4 Click OK when you have selected the color you want.

The color wheel dialog box disappears.

5 Close the Labels control panel.

The labels and colors you selected remain in effect until you change them.
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Changing the way the contents of windows appear

You can change the way the contents of Finder windows are displayed in the
different views available from the View menu (the icon view, the small-icon
view, and the list views by name, size, kind, label, and date).

To change the appearance of windows:

n Choose Control Panels from the Apple menu, and open the Views control panel.

Options for the size of
icons displayed in list
views

Options for layout 
of icons

Pop-up menu of fonts for
icon names and list views

Pop-up menu of font
sizes for icon names
and list views

Option to snap icons to
an invisible grid when-
ever they are moved

Options for information
displayed in list views

n Change any of these options:

n the font and font size used in all views (press to open the pop-up menu,
then drag to choose a font or a size)

n the arrangement of icons in icon and small-icon views
n the size of icons used in list views
n what information is included in list views, including folder sizes and the

amount of available space on the disk

The options you select remain in effect until you change them.

Changing the appearance of icons

You can customize icons by changing the icons themselves. If your computer
displays colors or shades of gray, you can have icons appear in a specific
color that’s associated with a label from the Label menu.
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Changing an icon

Using a graphics program, you can create or copy the picture you want to use
as an icon, and then paste it into an icon’s Info window.

Some icons can’t be changed, including those for control panels and other
parts of the system software. Every icon fits inside a 32-pixel square. (A
pixel, or picture element, is the smallest dot you can draw on the screen.)

To change an icon:

1 In a graphics program, select the picture that you want to use for the icon.

A moving dashed line
indicates the selected area
in many graphics programs.

2 Copy the picture by choosing Copy from the Edit menu.

3 Switch to the Finder, then click the icon you want to change. Don’t double-click.

4 Choose Get Info from the File menu.

The icon’s Info window opens.

5 Click the icon at the upper-left corner of the Info window to select it.

A box appears around the icon when it’s selected. If no box appears when
you click, the icon can’t be changed.

A box around the icon
indicates that it’s selected.
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6 Choose Paste from the Edit menu.

The picture you copied replaces the selected icon in the Info window. If the
picture is bigger than the icon, it automatically shrinks to fit.

7 Click the close box to close the Info window.

You can change an icon back to its original form by clicking the picture in
the upper-left corner of the Info window and choosing Cut from the Edit
menu.

Assigning a label and a color to an icon

You can add a label and its associated color to each icon. A label is different
from the icon’s name. The label is visible only when the contents of a
window are displayed as a list. The associated color is visible whenever the
computer is set to display colors or grays.

Labels provide a way to group related files. You can choose By Label from
the View menu, and all files with the same label will be grouped together. If
you have a color monitor, you can identify related icons by assigning a label
and its color to each group.

To assign a label and color to an icon:

1 Click the icon to select it.

2 Choose the label (and color) that you want from the Label menu.

See the section “Changing the Items in the Label Menu,” earlier in this
chapter, for information on changing the labels and colors.

Changing the highlight color

If your computer displays colors or shades of gray, you can use the Color
control panel to change the color your computer uses for highlighting
selected text on the screen.
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To change the highlight color:

1 Open the Color control panel.

Pop-up menu of choices
for highlight color

Pop-up menu of choices
for window color

You can also use the Color control panel to change the color of window
borders, as described in the next section.

2 Press the “Highlight color” pop-up menu to display it, and drag to choose a color or
choose Other.

If you choose a color, it appears in the “Sample text” box when you release
the mouse button.

If you choose Other, the color wheel dialog box appears.

New color or gray is in
upper half, current color
or gray in lower half

Circle indicates
selected color

Brightness control

Wheel shows colors or
grays available. (When
four colors or grays are
selected, letters appear
in the wheel indicating
color values.)

Numbers corresponding
to the selected color or
gray on the wheel
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3 To change the brightness of the color wheel, drag the scroll box up or down.

4 Click a color on the color wheel to select it.

The new color is displayed in the upper half of the color square if your
monitor is set to display 16 or more colors or grays. The current color
remains in the lower half of the square for comparison; you can click there to
go back to it.

5 To experiment with other colors or shades, drag the pointer around the wheel or click at
another point on the wheel.

Each new color is displayed in the upper half of the color square as you drag
or click.

6 Click OK when you have selected the color you want.

The color wheel dialog box disappears. The new highlight color is displayed
in the “Sample text” box in the Color control panel.
The highlight color you have specified takes effect immediately and remains
in effect until you change it.

Changing the color of windows

If your computer displays colors or shades of gray, you can use the Color
control panel to change the color of window borders.

You can also use the Color control panel to change the color your computer
uses for highlighting selected text on the screen, as described in the preceding
section.

To change the color of window borders:

n Press the pop-up menu labeled “Window color” to display it, and then drag to choose a
new color.

The color you choose takes effect immediately and remains in effect until you
change it.
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Displaying colors or grays

If your computer displays colors or shades of gray, you can use the Monitors
control panel to designate the number of colors or shades of gray you want
displayed. (The number of colors or shades your computer can display
depends on its video capability.)

If you have more than one monitor, you also use the Monitors control panel
to configure them, as described later in this chapter.

To display colors or shades of gray:

1 Open the Monitors control panel.

2 If you have more than one monitor, click the icon of the monitor whose colors you want
to adjust.

A dark border appears around the icon to show that it is selected.

3 Click the Grays or the Colors button.

Some monitors can display only shades of gray, even if you click the Colors
button.

4 Click the number of colors or shades of gray you want displayed on the selected
monitor (or click Black & White).

Your changes take effect immediately. The number of colors or shades of
gray you have specified remains in effect until you change it.
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Adjusting screen brightness

Most monitor models have brightness and contrast dials on the monitor or a
brightness dial on the computer itself.  See the Setting Up and Managing
Your Server for more information.
Note:  You should turn down the brightness if you’ll be away from your
computer for a while. If an image is left on the screen for several hours, it
may begin to “burn in” and damage the screen. You can use “screen saver”
programs, available from various sources, to dim the screen automatically or
display a moving image after a set period of inactivity.

Configuring multiple monitors

If you use more than one monitor with your computer, you use the Monitors
control panel to indicate the monitors’ positions and designate one as the
main monitor (the one that displays the menu bar). You also use the Monitors
control panel to set the number of colors or shades of gray you want
displayed. (See the earlier section “Displaying Colors or Grays.”)

To indicate monitor position:

1 Open the Monitors control panel.

Clicking this button displays a
dialog box, indicating the type of
video card to which the selected
monitor is connected.

Colors in this box
correspond to the
number of colors the
selected monitor is set
to display.

Drag this small menu bar to the
monitor you want to display the
menu bar.

The dark line around a monitor
icon indicates that it is selected.

Icons for the monitors connected to
the Macintosh, showing their ID
numbers and their relative positions.

Clicking this button dis-
plays each monitor’s ID
number on its screen.
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2 Check the ID numbers of your monitors by clicking the Identify button.

A large number appears in the center of each monitor’s screen; it corresponds
to the number of the icon in the control panel.
The ID numbers help you identify which icon belongs to which monitor.

3 Decide which monitor is your main monitor, and drag the menu bar to the top of that
monitor icon.

The menu bar snaps to the top of that monitor icon when you release the
mouse button.
If one of your monitors displays colors or shades of gray, you may want to
make it the main monitor so that you can use the color capabilities of your
programs and of the Finder.
If your monitors are different sizes, you may want to make the largest one the
main monitor, because some programs limit their window size to the size of
the main monitor.

4 Drag the icons of the other monitors to their positions relative to the main monitor.

To avoid becoming disoriented when you’re using the monitors, position the
monitor icons so that they correspond to their actual positions on your desk.
The pointer can cross from one screen to another where the monitors’ icons
touch in the control panel.

5 Choose Restart from the Special menu.

The positions you have specified remain in effect until you change them and
restart your computer.



Turning off the Empty Trash warning

When you choose Empty Trash from the Special menu, an alert box appears,
warning you that you will not be able to recover the contents of the Trash
once it’s emptied. (The warning helps you avoid throwing away items
unintentionally.)

To turn off this warning:

1 Click the Trash icon to select it.

2 Choose Get Info from the File menu.

The Info window for the Trash appears.

3 Click the checkbox labeled “Warn before emptying” to deselect it.

To turn the warning back on, click the checkbox so that an X appears.

You can also override the Empty Trash warning when it is on by holding
down the OPTION key when you choose the Empty Trash item.

Until you choose Empty Trash, items in the Trash continue to occupy space
on your disk.
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Adding application programs to your system

When you install an application program on your system, it is best to install it
in your home directory folder. If you are the system administrator and you
install a program that is to be used by all users of the system, install it in the
Applications folder.

To add the program to the Applications folder:

1 If the program is on a floppy disk, insert it in the floppy disk drive, and double-click its
icon to display the files or folders to be transferred.

2 Double-click the disk icon labeled with a slash character (/) to open it.

3 Locate the Applications folder icon, and double-click the icon to open the folder.

4 Drag the appropriate files or folders from the floppy disk to the open Applications
folder.

If you want to be able to start the program by double-clicking its icon on the
desktop, use an alias of its icon.

To create an alias:

n Highlight the icon, and choose Make Alias in the File menu.

You can move the alias icon to the desktop. You also can move it to the
Apple Menu Items folder in the System Folder to make it available in the
Apple menu.

Depending on how many users work with the installed programs you may
find it necessary to adjust the system memory cache. For details, see Server
Administration With A/UX 3.0.1.
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Appendix Menu Reference

This appendix provides a quick reference for the menu items that you
encounter while working in the Finder environment and the TextEditor
application. It describes the function of each menu item in the order in
which the items appear in each menu.



The Finder environment

This section describes the menu items to which you have access when you
are working in the Finder. The Finder is the program that creates the
desktop and that underlies other open programs. The Finder also grants
you easy access to all of the files, programs, and utilities on your system.

The Apple menu

The Apple menu lists available desk accessories and contains information
items identifying versions of software and their developers. Your Apple
menu also contains the items that you have installed in your computer’s
Apple Menu Items folder.

About This Macintosh...

This item identifies the hardware and system software you are using. The
system software version you are using is shown to the right of “System
Software.”  It also presents information regarding the allocation of
memory. When you switch to another program, this item becomes “About
program name” and displays proprietary information about the active
program.

128 Appendix  /  Menu Reference



Desk accessories

Desk accessories are miniature application programs. Several desk
accessories—Alarm Clock, Calculator, Chooser, Key Caps, Note Pad,
Puzzle, and Scrapbook—are shipped with your computer.

You can add desk accessories, folders, programs, and other objects by
placing them in the Apple Menu Items folder that is in your System
Folder. See “Installing an Item in the Apple Menu” in Chapter 7,
“Customizing the Finder Environment.”

The File menu

The File menu, shown in the following figure, contains the menu items
that help you manage your desktop environment.

New Folder

This menu item creates a new folder, also called a directory, in the active
window. Each new folder is created with the name “untitled folder.” You
can immediately change the name of the folder by typing a new name
while the title is still selected. The keyboard shortcut is COMMAND-N.

Open

This menu item opens the selected file, folder, or program in the Finder.
The keyboard shortcut is COMMAND-O.

The Finder environment 129



Print

This menu item prints whatever file is selected in the Finder by opening
the appropriate application program. The keyboard shortcut is
COMMAND-P.

Close Window

This menu item closes the active window. The keyboard shortcut is
COMMAND-W.

Close All

To choose this, pull down the File menu with the OPTION key held down.
The Close All item closes all open windows on the desktop.

Get Info

This menu item displays a window that contains information about the
currently selected file, folder, or program. This figure shows the Info
window for the letter1 file in the start folder.

The Info window reports the kind of file, its size, its location, its creation
date, the date the file was last modified, and the version of the program
that was used to create the file. The window also contains a text field in
which you can enter and store comments about the file. It is useful to store
such information as the version of the file, other files related to this one, or
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the version of the program if it’s not reported by the program. The
keyboard shortcut is COMMAND-I.

Sharing...

If file sharing is turned on, this menu item allows you to specify the
Macintosh file-sharing permissions for the currently selected folder (as
shown in the figure that follows).
Note:  Macintosh file-sharing permissions are somewhat different from
UNIX permissions. See Server Administration With A/UX 3.0.1 for more
information about UNIX permissions and how they correspond to Finder
permissions.

UNIX Permissions...

If you choose this item with a file icon selected, your screen displays the
UNIX Permissions dialog box for files.
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If you have highlighted a folder before choosing UNIX Permissions, your
screen displays the UNIX Permissions dialog box for folders.

This dialog box shows the selected folder’s permissions in UNIX
terminology. You can display its permissions in Macintosh terminology
by clicking “The Show Mac view” button. This dialog box appears.

You can change to the UNIX permissions again by clicking the button.

Duplicate

This menu item makes a copy of a selected file, folder, or program. The
keyboard shortcut is COMMAND-D.
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Make Alias

This menu item creates an alias of the selected file. The name of the alias
comprises the original filename and the word alias. You can move the
alias to any location in the file system and double-click its icon to open
and use the original file.

Put Away

This menu item restores to its original location a file, folder, or application
that was moved to the desktop. The keyboard shortcut is COMMAND-Y.

Find...

This menu item enables you to find a file anywhere on the system. It
allows you to select criteria for the search and to broaden or narrow the
area to be searched. If you choose Find, the dialog box shown in the next
figure appears. This dialog box allows you to search for a file by its name.
This search is not case sensitive. The keyboard shortcut is COMMAND-F.

If you click More Choices, the dialog box shown in the next figure
appears. This dialog box allows you to use more criteria in your search.
See “Finding a File or a Folder” in Chapter 3, “Using Files and
Folders,” for more information.
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The Fewer Choices button redisplays the initial dialog box.

Find Again

This menu item allows you to repeat the search you performed with Find.
See the description of Find just given. The keyboard shortcut is
COMMAND-G.

Page Setup...

This menu item presents the Page Setup dialog box for the printer type
that you have selected in the Chooser. This figure shows the Page Setup
dialog box for a LaserWriter printer.

The Page Setup dialog box displayed by other programs may look
different. See the manual that came with your program for more
information.

Print Window...

This menu item prints a list of the contents of the active window. When
you choose this item, the Print dialog box appears. When you click OK, a
directory listing is sent to the printer you have selected in the Chooser.
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The Edit menu

The Edit menu contains items that you use to edit text in windows. You
can also use the editing items with most desk accessories.

Undo

This menu item nullifies the last text-editing or formatting change that
you made. It does not nullify command execution. The keyboard shortcut
is COMMAND-Z.

Cut

This menu item copies any selected text or graphics to the Clipboard and
removes the selection from the window. The cut material is stored in the
Clipboard until it’s replaced by text or graphics sent there as the result of
another Cut or Copy operation. The keyboard shortcut is COMMAND-X.

Copy

This menu item copies any selected text or graphics to the Clipboard but
does not remove it from the window. The copied material is stored in the
Clipboard until it’s replaced by text or graphics sent there as the result of
another Cut or Copy operation. The keyboard shortcut is COMMAND-C.
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Paste

This menu item inserts the contents of the Clipboard into the window at
the insertion point. The keyboard shortcut is COMMAND-V.

Clear

This menu item removes any selected text or graphics from the window
but does not copy it to the Clipboard. Any material removed with the
Clear item is no longer available. Choosing Clear is equivalent to pressing
the DELETE key.

Select All

This menu item selects all of the text and graphics in the window. The
keyboard shortcut is COMMAND-A.

Show Clipboard

This menu item displays the contents of the Clipboard in a separate
window.

The View menu

The View menu provides items for altering the way the Finder displays the
contents of a disk or a folder. A checkmark appears next to the active
listing method. See Chapter 3, “Using Files and Folders,” for information
on uses of the View menu.

Small Icon

When you view the contents of a disk or folder by small icon, the Finder
displays miniature representations of each file, folder, or program icon in
this window.
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Icon

When you view the contents of a disk or folder by icon, the Finder
displays the full-size representation of each file, folder, or program icon in
the window.

Name

When you view the contents of a disk or folder by name, the Finder
displays an alphabetized list of the different files, folders, and programs in
the window.
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The list in the window has five columns:
n Name:  This column shows the names of the files, folders, or programs

in the window.
n Size:  This column shows how much memory each item occupies on

the disk.
n Kind:  This column shows whether an item is an application program,

folder, or file. If it is a file, the file type is shown.
n Label:  This column shows the label you have given to each item by

means of the Label menu (described later in this appendix).
n Last Modified:  This column shows the date and time that the file,

folder, or program was last changed.
Note:  You can enlarge the window to see all of the information.

Size

When you view the contents of a disk or folder by size, the files, folders,
and programs in the window are listed in order, from largest to smallest.

The size of a file or program is the amount of memory it occupies. After
the name of each item, a number followed by a K is displayed. The
number 209K next to the program A/UX Startup means that it occupies
209 kilobytes of memory on the disk. (A kilobyte is equal to 1024 bytes.)
A standard high-density floppy disk can hold up to 1.4 megabytes (MB)
of information. (A megabyte is equal to 1024 kilobytes.) The average
hard disk for the Apple Workgroup Server 95 can hold up to 230 MB of
information.
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Kind

When you view the contents of a disk or folder by kind, the files, folders,
and programs are listed alphabetically by type.

Label

The Label menu in the Finder allows you to give each file or folder a label
that categorizes it. (See “The Label Menu,” later in this appendix, for
further information.) Viewing items by label sorts them in the order in
which the labels occur in the Label menu.
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Date

When you view the contents of a disk or folder by date, the files, folders,
and programs in the window are displayed with the most recently created
or modified one listed first.

Note:  You can click each column heading to view the contents of a
window in a specific way. For example, if you want to view the contents by
kind, click the Kind column heading.

The Label menu

The Label menu supplies a list of labels that you can apply to any file or
folder. You can then choose Label in the Views menu to list items
according to the labels you have assigned to them. If you have a color
monitor, the labels appear in different colors.  For more information, see
“Assigning a Label and a Color to an Icon” and “Changing the Items in
the Label Menu” in Chapter 7, “Customizing the Finder Environment.”
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The Special menu

The Special menu contains the items you use to log out, shut down the
system, and restart the computer. It also provides items that you use for
special tasks, such as deleting the files that you placed in the Trash.

Clean Up Window

This menu item rearranges icons on a disk or in a folder so that they are
easier to see. You can use this item only when you are viewing the
contents of a disk or folder by icon or by small icon. If you hold down
the OPTION key while you pull down the Special menu, you can clean up
the window by name, kind, label, and so on. The name of the Clean Up
item changes depending on the last viewing method used.

Empty Trash...

This menu item deletes any files, folders, or programs you have placed in
the Trash. You can recover items placed in the Trash before you empty
the Trash. Once you empty the Trash, the items cannot be recovered.

Eject Disk

This menu item causes the selected floppy disk to be ejected. The
keyboard shortcut is COMMAND-E.
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Erase Disk...

This menu item completely erases any information on the selected disk.
To use this item, you must first select the disk you want to erase.

WARNING  When you erase a disk, its contents cannot be recovered.

Restart

This menu item shuts down the computer and starts it up again. When you
use this item, you must enter the password for the root account unless
you are already logged in as root.

Shut Down

This menu item shuts down the computer. To use this command, you must
enter the password for the root account unless you are already logged in
as root.

Logout

This menu item ends the current work session. When you choose this item,
all open programs are closed and you return to the Login dialog box,
unless the auto-login feature is enabled. If this feature is enabled, all
programs are shut down and processes are stopped, and your desktop is in
the same state as when you start up your computer. For a complete
discussion of the auto-login feature, see “Logging In to an Account” in
Chapter 2, “Getting Started With A/UX 3.0.1.”

The Help menu

The Help menu makes Balloon Help available or turns Balloon Help off.
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About Balloon Help...

This menu item displays a brief description of how Balloon Help works.

Show Balloons

This menu item causes a balloon with a brief help message to appear
whenever you position the pointer on an on-screen object.

Finder Shortcuts

This menu item offers you quick summaries and shortcuts for the features
of the Finder.

The Application menu

This menu is labeled by the icon of the active application program and is
located at the right end of the menu bar.

The Application menu contains a list of the  programs that are currently
running, such as the Finder and CommandShell. To make a program
active, choose it from the list at the lower part of this menu.

The Hide and Show items let you make windows of open programs
invisible without closing them. This feature is useful when you are
working with
many windows and want to avoid confusion about which windows belong
to which program.

The Finder environment 143



Hide Program

This menu item hides all windows of the active program. For example, if
the Finder is the active program, this menu item causes all of the Finder
windows to disappear, and switches you to whichever program was most
recently opened. When a program other than the Finder is active, this
menu item switches you to the Finder.

Hide Others

This menu item hides all windows except those of the active program.

Show All

This menu item redisplays hidden windows for all open programs.

The TextEditor program

TextEditor is a word-processing program that lets you create text
documents by means of the mouse and Macintosh-like editing techniques.
See Chapter 5, “Working With TextEditor,” for a tutorial on its use.

The TextEditor File menu

The TextEditor File menu contains items for creating, opening, closing,
saving, and printing TextEditor files.
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New...

This menu item creates a new document. When you choose New, the New
dialog box appears. This dialog box is shown in the following figure. You
use this dialog box to enter a name for the document and select a folder in
which it will be stored. The keyboard shortcut is COMMAND-N.

Open...

This menu item allows you to open documents and text-only files created
with TextEditor. When you choose Open, an Open dialog box appears and
allows you to select a file. The keyboard shortcut is COMMAND-O.
Note:  When you open a file, it appears in a new window. However, if you
try to open a document that’s already open in another window, that
window is brought to the front.

Close

This menu item closes the active window. The keyboard shortcut is
COMMAND-W.

Save

This menu item saves the file in the active window under the file’s current
name, without closing the window. The Save item is dimmed if the
contents of the window haven’t been modified since the file was last saved.
The keyboard shortcut is COMMAND-S.
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Save as...

This menu item displays a dialog box that allows you to make a copy of
the file in the active window and save it under a different name. This
action allows you to continue editing the file under a new name. The old
file retains its original name without being changed.

Save a Copy...

This menu item displays a dialog box that allows you to save the file in the
active window as a new file with the name “Copy Of Filename.” You can
then continue editing the original file.

Revert to Saved

This menu item throws away any changes you have made since you last
saved the file in the active window. This item is dimmed if you haven’t
modified the file since you last saved it.

Page Setup...

This menu item displays a dialog box that allows you to set parameters for
printing a file; the dialog box is the standard Page Setup dialog box for
the type of printer that you have selected in the Chooser. See Chapter 6,
“Printing From the Desktop,” for more information.

Print Selection

This menu item prints the selected contents of the active window.

Quit

This menu item closes the TextEditor program and returns you to the
Finder, first allowing you to save all open documents. The keyboard
shortcut is COMMAND-Q.
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The TextEditor Edit menu

You use the items in this menu to change the contents of the active
TextEditor window. The TextEditor Edit menu contains a few special
menu items in addition to the usual Macintosh editing commands.

Undo

This menu item nullifies the last text-editing or formatting change that
you made. The keyboard shortcut is COMMAND-Z.

Cut

This menu item copies any selected text to the Clipboard and removes the
text from the window. The text is stored in the Clipboard until it’s
replaced by text sent there as a result of another Cut or Copy operation.
The keyboard shortcut is COMMAND-X.

Copy

This menu item copies any selected text to the Clipboard but does not
remove it from the window. The text is stored in the Clipboard until it’s
replaced by text sent there as a result of another Cut or Copy operation.
The keyboard shortcut is COMMAND-C.
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Paste

This menu item inserts the contents of the Clipboard into the window at
the insertion point. The keyboard shortcut is COMMAND-V.

Clear

This menu item removes any selected text from the window. Once text is
removed using the Clear item, it is no longer available. Choosing Clear is
equivalent to pressing the DELETE key.

Select All

This menu item selects all of the text in the window. The keyboard
shortcut is COMMAND-A.

Show Clipboard

This menu item displays the contents of the Clipboard in a separate
window.

Format...

This menu item displays a dialog box offering a selection of fonts and
sizes that you can apply to text in the active window. The next figure
shows TextEditor’s Format dialog box.

The keyboard shortcut is COMMAND-Y.
Note:  The font and size you select applies to all of the text in the active
window, not just the current selection in that window.
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Align

This menu item aligns any selected text with the top line of the selection.

Shift Left

This menu item moves any selected text one tab stop to the left. The
keyboard shortcut is COMMAND-[ (left bracket).

Shift Right

This menu item moves any selected text one tab stop to the right. The
keyboard shortcut is COMMAND-] (right bracket).
Note:  If you hold down the SHIFT key while choosing Shift Left or Shift
Right, the selected text shifts by one space rather than by one tab.

The TextEditor Find menu

You use items in this menu to search for and replace text in
TextEditor windows.

Find...

This menu item displays the Find dialog box, which allows you to find the
text string that you specify. By default, TextEditor searches forward from
the selected text in the active window and stops searching when it reaches
the end of the document; it doesn’t go back to the beginning of the
document. The keyboard shortcut is COMMAND-F.

Find Same

This menu item repeats the last Find operation on the active window. The
keyboard shortcut is COMMAND-G.
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Find Selection

This menu item finds the next occurrence of the search string in the active
window. The keyboard shortcut is COMMAND-H.

Display Selection

This menu item causes the selected text in the active window to scroll into
view.

Replace...

This menu item displays a dialog box that allows you to search for a
specified text string throughout a file and replaces that string with a
different string. The keyboard shortcut is COMMAND-R.

Replace Same

This menu item repeats the last Replace operation on the active window.
The keyboard shortcut is COMMAND-T.

The TextEditor Mark menu

A marker is a portion of text or a position in a block of text that has been
given a name. Markers help you navigate within documents that contain
blocks of text that you must locate repeatedly—as, for example, in
program listings.

Mark...

This menu item displays a dialog box that allows you to create a new
marker in a TextEditor document. The keyboard shortcut is COMMAND-
M.

Unmark...

This menu item displays a dialog box that allows you to remove a marker
from a TextEditor document.
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List of markers

This part of the window lists all existing markers. You can jump to the
location of a marker by choosing the marker’s name in this menu.

The TextEditor Window menu

The TextEditor Window menu allows you to tile or stack any TextEditor
windows on the desktop.

Tile Windows

This menu item tiles any open windows—that is, displays them alongside
each other.

Stack Windows

This menu item stacks any open windows—that is, displays them layered
on top of one other.

List of open windows

This part of the menu lists all open TextEditor windows. A checkmark
appears next to the active window. You can change the active window by
choosing its name in this menu.
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Glossary

active program  The program you’re currently
using. Several programs can be open at a time, but
only one is active. Open programs are listed in the
Application menu; a checkmark indicates the active
program.
active window  The window in which you can
work, and where the next action takes place. An
active window’s title bar is highlighted and it is the
frontmost window on the screen. See also titlebar.
alert box  A box that contains a message. The
message warns you that you’re asking your
computer to do something it can’t do, or that you’re
about to destroy some of your information. In these
cases, the message is often accompanied by the alert
sound.
alias  In Macintosh terminology, an icon that
represents a specific file, folder, or disk icon, and
that you can open in place of the original icon. You
can leave the original file in its place while moving
the alias icon to another place in the file system for
convenience. By default, the name of the alias icon
is the name of the original file, plus the word alias.
Apple menu  The menu at the far-left end of the
menu bar. Use this menu to get information about
memory use, to open desk accessories and items in
the Apple Menu Items folder, and to change Control
Panel settings.
application  A program used to perform a particular
task, such as computer-aided drawing, document
preparation, accounting, or payroll management.
See also program.

ASCII text file  See text file.
back up  To make a copy of files or folders onto
another disk or onto tape so that you won’t lose
information if the original file or folder is lost or
damaged.
bit  Short for binary digit. The smallest unit of
information the computer can use.
button  An image of a push-button in a dialog box.
You click the button to select an option or to
complete an action.
byte  A unit of information. One byte is equal to
eight bits. See also bit.
case sensitive  Able to distinguish between
uppercase characters and lowercase characters.
Programming languages are case sensitive when
they require all uppercase letters, all lowercase
letters, or proper use of uppercase and lowercase
letters.
checkbox  A small box associated with an option in
a dialog box or window. When you click the
checkbox, you can change the option or affect
related options. An option is on when you see an X
in the checkbox.
choose  To pick a command from a menu. You
normally choose a command after you select
something for the command to act on—for example,
selecting a disk and choosing the Open command
from the File menu.



click  (verb) To position the pointer on something,
and then press and quickly release the mouse button.
(noun) The act of clicking.
Clipboard  A place in the computer’s memory that
temporarily stores whatever you last cut or copied
by using Edit menu commands.
close box  The small box on the left side of the title
bar of an active window. Clicking the close box
closes the window.
control panels  Programs that you use to change
features such as mouse tracking, desktop appearance, sound, and
keyboard operation. A window with available
control panels appears when you choose Control
Panels from the Apple menu. See also Apple menu.
current directory  The directory in which you are
currently working. This directory is the starting
reference point for all relative pathnames you enter.
Also called the working directory.
cursor  See insertion point.
default A preset value or action that the system uses
or performs unless you give it a different instruction.
dialog box  A box that appears on your screen,
containing a message or requesting information from you.
Sometimes the message warns you that you’re asking your
computer to do something it can’t do, or that you’re
about to destroy information. In these cases, the
message is often accompanied by a an alert sound.
directory  A file that contains a list of other files;
similar to a folder in a Macintosh hierarchical file
system.
double-click  To position the pointer where you
want an action to take place, and then press and
release the mouse button twice in quick succession
without moving the mouse.
drag  To position the pointer on an object on the
screen, press and hold down the mouse button,
move the mouse, and release the down mouse
button. When you release the mouse button, you
either confirm a selection or move the object to a
new location.
Ethernet  A hardware medium designed to provide
high-speed interconnection between computers.

execute permission  Permission to execute (run) a
file, usually an application or program. See also
read permission, write permission.
file  (1) For UNIX-based operating systems, an
array of bytes; no other structure is implied by
UNIX systems, which even treat peripheral devices
like files. (2) For the Macintosh Operating System,
any named, ordered collection of information stored
on a disk. Application programs and documents are
examples of files. You create a file when you type
text or draw graphics, give the material a name, and
save it on a disk.
Finder  The application that maintains the
Macintosh desktop and starts up other programs.
You use it to manage documents and applications
and to get information to and from disks. It controls
the desktop you see upon starting up your computer.
folder  A holder of documents and applications on
the desktop. Folders, like UNIX file system
directories, allow you to organize information in a
hierarchical fashion.
font  A collection of print characters unified by a
distinctive look. Times, Geneva, and Courier are
examples of fonts.
fork  A part of a Macintosh file; each file has two
forks. The data fork stores the text only, and the
resource fork stores formatting information such as
font and tab settings.
format  (1) To divide a disk into tracks and sectors
where information can be stored. Blank disks must
be formatted before you can save information on
them. (2) To change the appearance of a text tile by
using different fonts, indents, tab settings, margins,
and so forth.
hierarchical file system (HFS)  A method of
organization, used by the Macintosh Operating
System, in which disk files are grouped together
within directories and subdirectories (folders within
folders). HFS is used on hard disks and on floppy
disks. In a hierarchical file system, a file is specified
by its pathname rather than by a single filename.
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highlight  To make something visually distinct. For
example, when you select a block of text using
TextEditor, the selected text is highlighted—it
appears as light letters on a dark background rather
than as dark letters on a light background.
home directory  Usually the first directory you
enter upon login, as designated in the file
/etc/passwd. You can tailor your environment by
modifying various files in your home directory.
home directory folder  The folder that represents
your home directory on the Finder. See also
home directory.
icon  An image on the screen, usually representing
an item such as a file, document, disk, or application
program that you can select and open.
I-beam  A pointer used to position the insertion
point or to select a block of text. It resembles a
capital letter I. See also insertion point.
insertion point  The place in a document where text
you type will be added. The insertion point appears
as a blinking vertical bar. It is not the same as a
cursor.
kilobyte (K) A measurement of information storage.
A kilobyte is equal to 1024 bytes.
log in  To identify yourself to the system by
entering the login name of your account and your
account password.
login name  The name of a user’s account. Used for
identification purposes. Same as the account name.
MacPartition  The part of your Apple Workgroup
Server 95 hard disk that contains the A/UX Startup
program and related files and some system
administration commands that you can use if you
cannot start up A/UX.

manual page (Also called man page.)  Reference
material describing a specific command. With the
Apple Workgroup Server 95, you can display a
manual page on your screen by entering the
command man commandname in CommandShell.
(Replace the placeholder commandname with the
name of the command you want to learn about.)
menu  A list of actions or options presented by an
application program, from which you can choose.
With Macintosh-style programs, a menu appears
when you point to the menu’s title in the menu bar
at the top of the screen and press the mouse button.
Dragging through the menu and releasing the mouse
button while a command is highlighted chooses
that command.
mouse  A small device that you move around on a
flat surface next to your computer. The mouse
controls a pointer on the screen whose movements
correspond to those of the mouse. You use the
pointer to select operations, move data, and draw
images on the screen.
mouse button  The button on the top of the mouse.
In general, pressing the mouse button initiates some
action affecting whatever is under the pointer, and
releasing the button completes the action.
multitasking  The ability of an operating system
such as A/UX to perform multiple activities
simultaneously.
network  A collection of interconnected,
individually controlled computers, along with the
hardware and software used to connect them. A
network allows users to share data and peripheral
devices and to exchange electronic mail.
operating system  Low-level software that controls
a computer by performing such basic tasks as
input/output (I/O), memory management, and
interrupt handling.

Glossary 155



password  A unique set of characters that must be
entered before a user can gain access to a system or
perform some actions. For example, you must know
the password for the root account to shut down the
system.
pointer  (1) An arrow or other symbol on the screen
that moves as you move the mouse. You use the
pointer to choose commands, select and move icons
and text, and draw images. (2) In programming, an
item of information consisting of the memory
address of some other item.
pop-up menu  A menu, usually appearing inside a
dialog box, that is hidden until you move the point
to its title and press the mouse button. A pop-up
menu is indicated by a box with a shadow and a
downward-pointing triangle next to the menu’s
name. The name is also the current menu choice.
Compare pull-down menu. See also dialog box.
port  A socket on the back panel of a computer
where you plug in a cable for connection to a
network or a peripheral device.
program  A file containing coded instructions to the
computer. Programs can be very simple, such as the
Alarm Clock control panel, or highly complex, such
as a desktop publishing program.
See also application.
pull-down menu  A menu that is hidden until you
move the pointer to its title and press the mouse
button. Menus in the menu bar are pull-down
menus. Compare pop-up menu.
read permission  Permission to view a file but not
to make changes (write) to the file. See also execute
permission, write permission.
ROM  Acronym for read-only memory. Memory
whose contents can be read, but not changed, and
that is used for storing permanent information.
root  (1) The top directory in a UNIX directory
hierarchy. Indicated by a slash character (    /    ), it is
the first element in every absolute pathname. (2)
The user with unlimited system privileges. Also
called the superuser.

scroll bar  A rectangular bar that can be along the
right or bottom of a window. Clicking or dragging
in the scroll bar causes your view of the window
to change.
SCSI  See Small Computer System Interface.
select  To designate where the next action takes
place. To select something using a mouse, you click
an icon or drag across text. In some applications,
you can select items in menus by typing a letter or
number at a prompt, by using a combination
keypress, or by using arrow keys.
SHIFT-click  To hold down the SHIFT key while
clicking to select more than one icon at a time, or
extend a selected block of text without dragging
through it again.
size box  A box in the lower-right corner of some
active windows. Dragging the size box resizes the
window.
Small Computer System Interface (SCSI)  A
specification of mechanical, electrical, and
functional standards for connecting small computers
with intelligent peripheral devices such as hard
disks, printers, and CD-ROM disks.
System Folder  A folder containing system
software. An A/UX system contains a minimum of
five system folders; however, only one can be active
at a time. The active System Folder contains a
miniature computer in its folder icon.
system software  Software that supports application
programs by managing memory and by
communicating with input and output devices. See
also application.
text box  The rectangular field in a dialog box
where you can type information. See also dialog
box.
text file  A file containing information expressed in
text form and whose contents are interpreted as
characters, using the American Standard Code for
Information Interchange (ASCII) format. TextEditor
saves the text of a file as a text file (the data fork)
and formatting information in a separate file (the
resource fork). See also fork.
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text-only file  See text file.
tile  To arrange a group of windows so that their
edges are touching one another (like the tiles on a
tiled floor), rather than overlapping one another.
title bar  The horizontal bar at the top of a window
that shows the name of the window. When the
window is active, the title bar is highlighted with a
series of horizontal lines. You can move the window
by dragging the title bar.
UNIX operating system  A general-purpose time-
sharing system and related set of utilities, originally
developed at AT&T Bell Laboratories. A/UX is an
enhanced version of the UNIX operating system,
combining UNIX with the Macintosh interface.
user account  The permission to log in to A/UX
under an assigned login name, usually with a unique
password, and usually with a specifically assigned
home directory. See also home directory, login
name.

user name  See login name.
user permission  Permission for the owner of the
file to use the file. If a file has only user permission,
no other users can read it, write to it, or run
(execute) it. See also execute permission, read
permission, write permission.
window  The area that displays information on a
desktop; you view a document in a window. You
can open or close a window, move it around on the
desktop, and sometimes change its size, scroll
through it, and edit its contents.
write permission  Permission to write to a file. See
also execute permission, read permission.
zoom box  A small box in the upper-right corner of
some windows. Clicking the zoom box resizes the
window so that you can see all of its contents (if
possible); clicking the zoom box again returns the
window to its original size.
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Index

A
About Balloon Help menu item  143
About This Macintosh menu item  128
accounts, logging in  26-28
active system folder icon  38
Alarm Clock  103-104
alert sound  108-111
alias  47-48

application programs and  125
locking  50
TextEditor and  65-66

Align menu item  149
amber light  57, 59-60
Apple DocViewer  xiv
Apple menu  128-129

installing items in  10
Apple Menu Items folder  100

alias and  47
AppleShare Pro, logging out and  34
AppleTalk network  90-92

zones  93
Application menu  12, 143-144

CommandShell and  30-31
error monitoring and  33
program switching and  18

application programs, adding  125
arrow pointer  16
arrows, scroll  9
ASCII text file  64
Autologin file  26, 34
A/UX 3.0.1 operating system  2, 24-25

command icon  39
shutting down  34-35

B
backing up  55-56

sounds and  111
tape cassettes  57-62

Balloon Help  20-21, 142-143
bars, scroll  9-10
binary data file icon  39
bitmapped fonts  100

C
Cancel button  25
Cancel option  79
case sensitivity  27, 77-78
caution signal  60
CD-ROM discs  56-57
Change Password menu item  28-29
characters

invisible  80
repeat rate  106-107

Chooser menu item  92-93
Clean Up menu item  43
Clear Lines Off Top menu item  32
Clear menu item  136, 148
Clear Up Window menu item  141
clicking  5

from keyboard  108
Clipboard  17, 69
Close All menu item  130
close box  10-11
Close menu item  18, 76, 145
Close Window menu item  11, 130



closing
documents  18
System Console window  32
windows  10-11

colon (:)  20
file names and  41

color
desktop pattern and  113
highlight  118-120
icons and  118
labels and  114-115

Color control panel  119-120
color wheel  119-120
COMMAND key  13-14
command, dimmed  12
COMMAND–0 (zero)  31
COMMAND–[ (left bracket)  149
COMMAND–] (right bracket)  149
COMMAND–A  136, 148
COMMAND–C  17, 135, 147
COMMAND–D  19, 132
COMMAND–E  141
COMMAND-F  44-45, 133, 149
COMMAND–G  44-45, 134, 149
COMMAND–H  150
COMMAND–I  49, 130
COMMAND–M  150
COMMAND–N  129, 145
COMMAND–O  129, 145
COMMAND–P  130
COMMAND–Q  19, 146
COMMAND–R  150
COMMAND–S  17, 145
COMMAND–Shift  57
COMMAND–Shift-Clear  108
COMMAND–T  150
COMMAND–V  17, 136, 148
COMMAND–W  130, 145
COMMAND–X  17, 135, 147
COMMAND–Y  133, 148
COMMAND–Z  135, 147

Commands menu  32
CommandShell program  29-31

error monitoring and  33
printing and  92

computers, turning on and off  2-3
Control Panels window  102-103

keyboard and  106
mouse and  105-106

copying
between documents  74-76
documents  19
to floppy disk  54-56
icons  118

Copy menu item  17, 135
in TextEditor  74-75, 147

Courier font  xiii
creating

documents  16, 66
folders  42

Cut menu item  17, 69, 135, 147

D
data-compression feature  57
DAT (digital audio tape)  58
date, changing  102-103
Date menu item  140
DDS (digital data storage)  58
DELETE key  74, 136, 148
desk accessories  129
desktop

changing pattern of  112-113
Finder program and  3-4

dialog boxes  12
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diamond-shaped symbol  32
digital audio tape (DAT) cassettes  58
digital data storage (DDS) tape cassettes  58
dimmed command  12
directory. See folders
directory dialog box  42-43
disks  52-57
Display Available Fonts menu item  95
Display Selection menu item  150
documents  144-151

closing  18
copying  19
creating  16, 66
editing  17, 72-79
listing  50
naming  42-43
saving  17, 70-71

double-clicking  5
changing speed  106
from keyboard  108

Download Fonts menu item  95-96
dragging  5

from keyboard  108
drop box icon  38
Duplicate menu item  19, 132

E
Easy Access control panel  108
Edit menu  17, 68-69, 135-136

formatting and  79
eject button  61
Eject Disk menu item  56, 141
Empty Trash menu item  14, 124, 141
Entire Word button  77-78
Erase Disk menu item  142
error-correction feature  57
errors, CommandShell and  33
Ethernet card  90-91
executable file icon  40

F
Fast option  105
file hierarchy icon  25
File menu  70-71, 129-134

icons and  6
program opening and  15

files
ASCII  64
copying  54-56
finding  43-46
getting information on  48-49
installing in System Folder  98-99
locking  49-50
Macintosh  94-96
marking places in  83-86
name restrictions  41
opening  72-73
read-only  73
removing from System Folder  99
resource fork  64
restoring  55
text-only  64

file sharing  131
Find Again from the File menu item  44-45
Find Again menu item  134
Finder program  128-144

CommandShell and  31
desktop and  3-4
environment  128

Finder Shortcuts menu item  143
Find from the File menu item  44-45
Find menu item  43-46, 133

in TextEditor  76-77, 149
Find Same menu item  149
Find Selection menu item  150
fixed-size fonts  100
floppy disk icon  41
floppy disks  52-57
folder icon  38
folders  41-42

copying  54-56
finding  43-46
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fonts
downloading  95-96
installing  101
removing  101
selecting  80
transferring to LaserWriter  95-96
using  100-101

Format menu item  80, 148
formatting  79-86

disks  52-53
information file  64

G
General Controls panel  102-103, 112-114
Get Info menu item  130

alias and  48
files and  48-49

graphics program  117
grays, shades of  121
green light  59-60
Guest account  26

H
hardware  128
Help menu  12, 20-21, 142-143
hidden contents, viewing  9
Hide Balloons menu item  21
Hide CommandShell menu item  33
Hide Others menu item  144
Hide Program menu item  144
home directory  25

icon  39
humidity, tape drive and  61
hyphen (-)  41

I, J
I-beam pointer  16
Icon menu item  137
icons

alias and  47
changing a file's  49
changing appearance of  116-118
defined  4
file hierarchy  25
file-system  40-41
Finder program  38-41
flashing  32
floppy disk  52

folder  38-39
hard disk  56
MacPartition  25
name changing  20
no write permission  73
opening  6
rearranging  43
System Folder  98
TextEditor  65-66
text file  39

ID numbers  123
Info window  130

for alias  48
for file  49

insertion point  16, 67
adjusting blinking of  114

internal tape-backup unit  57-62

K
keyboard

adjusting  106-108
layout of  108
shortcuts  13

Keyboard control panel  107-108
Kind menu item  139
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L
Label menu  114-115, 140
Label menu item  139
Labels control panel  115
labels, icons and  118
LaserWriter Font Utility  95-96
LaserWriter IISC printer  90
LaserWriter SC printer  90
line breaks  67
Literal button  77-78
loading procedure  59
LocalTalk cable system  90
locked folder icon  38
locking

files  49-50
floppy disk  54
tape cassette  61

logging in  26-28
logging out  34
Login dialog box  26-29
Login System Folder  26, 98
Logout menu item  34, 142

M
Macintosh file system icon  41
Macintosh Operating System  24
Macintosh program icon  40
MacPartition icon  25
Make Alias menu item  47, 65, 125, 133
marking  83-86, 150-151
Mark menu item  84-85, 150
Media Recognition System (MRS)  58
memory  138

changing allocation  49
menu bar  3-4, 12

main monitor and  123
menus  12-13

adjusting blinking of items  113-114
defined  4

messages
alerts  32
A/UX advisory  25
clearing  32
Empty Trash menu item and  124
printing and  94
system  31
warning of shut down  35

monitors, configuring multiple  122-123
Monitors control panel  121-122
mouse

adjusting movement  105-106
using  4-5

Mouse Keys feature  108

N
Name menu item  137-138
names

changing icon  20
of documents  42-43

login  27
restrictions for files  41

New Folder menu item  42, 129
New menu item  145
Notification Levels menu item  32-33

O
on-line documentation  xiv
Open menu item  6, 15, 129

in TextEditor  72-73, 145
OPTION key  13-14

Clean Up Window and  43
Empty Trash menu item and  124
File menu and  130
Special menu and  141

Options menu  28-29
outline fonts  100
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P
Page Setup menu item  92, 134, 146
passwords  26

changing  28-29
Password text box  27
Paste menu item  17, 69, 136

in TextEditor  75, 148
pasting

between documents  74-76
icons  118
text  68-69

patterns  112-113
percent sign (%)  64
Personal LaserWriter SC printer  90
pixel  117
pointer  4-5, 16

keyboard and  108
pop-up menus  12
PostScript fonts  95
POWER ON key  2
Preferences menu  32-33
pressing  5
printers

choosing  92
connections  90-92

printing
Macintosh techniques  94-96
in TextEditor  86-87

Print menu item  130
PrintMonitor program  94
Print Selection menu item  87, 146
Print Window menu item  87, 134
programs

switching  18
working with  15-19

progress bar  24
pull-down menus  12
Put Away menu item  48, 56, 133

Q
Quit menu item  19, 88, 146

R
read permission  40, 73
recording sounds  110-111
Replace All option  79
Replace menu item  78-79, 150
Replace Same menu item  150
resource fork  64, 71, 79
Restart menu item  35, 142
restoring  55
Retrospect Remote  55, 58
Revert to Saved menu item  71, 75, 146
root account  25
root privileges  34

S
Save a Copy menu item  71, 146
Save As menu item  70-71, 146
Save Format Info menu item  71, 79
Save menu item  17, 71, 145
scalable fonts  100
screens

brightness of  122
customizing  112-121

screen saver programs  122
script icon  40
scroll box  9
Search Backwards option  77, 79
searching. See Find menu item
Select All menu item  74, 136, 148
selecting text  16, 68
Sharing menu item  131
shell script icon  40
shell utility  29-31
SHIFT key

mouse movement and  5
searches and  77
Shift Left/Right and  149

Shift Left menu item  80, 149
Shift Right menu item  80, 149
Show All menu item  144
Show Balloons menu item  20, 143
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Show Clipboard menu item  136, 148
Shut Down menu item  3, 35, 57, 142
size box  8
Size menu item  138
Small Computer System Interface (SCSI) devices  3
Small Icon menu item  136-137
software, system  128
Sound control panel  109-111
Special menu  34-35, 43, 141-142

Trash and  14
turning computer off and  3

Stack Windows menu item  83, 151
start account  26
Startup Items folder  99
Startup program  24-25
Startup System Folder  98
stationery pad  49
status lights  57, 59-60
submenus  13
System Console window  25, 31-33
System Folder  98-99

fonts and  101
System Folder window  9, 99
system software  128

T
tab settings  80
tape cassettes  57-62
tape drive

environmental concerns  61
head cleaning  60, 62

temperature, tape drive and  61
text

aligning  80
deleting  74
editing  68-69
entering  66-67
finding  76-77
formatting  80
replacing  78-79
selecting  68

TextEditor program  64, 144-151
Edit menu  147-149
File menu  144-146
Find menu  149-150
Mark menu  150-151
opening  15
quitting  88
starting  65-66
Window menu  151

text file icon  39
text-only file  64
Tile Windows menu item  82, 151
time, changing  102-103
title bar  7
tracking, changing speed  105
Transmission Control Protocol/Internet Protocol

(TCP/IP)  92
Trash  14

disk ejecting and  56
emptying warning  124
System Folder and  99

TrueType fonts  100
tutorial  65

U
Undo menu item  135, 147
UNIX operating system  2

command icon  39
file system icon  40
printing and  92

UNIX Permissions menu item  131-132
Unmark menu item  86, 150
utility programs  29-31

V
variable-size fonts  100
Very Slow option  105
View menu  50, 136-140
Views control panel  116
vi (visual editor) text editor  64
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W, X, Y
Window menu, formatting and  79
windows  151

active  7
arranging multiple  81-83
changing appearance of  116
changing size  8
closing  10-11
colors of  120
defined  4
hidden contents  9
moving  11

Wrap-Around Search option  77, 79
write permission  73

Z
zoom box  8
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The Apple Publishing System

Basic Skills was written, edited, and composed on a desktop
publishing system using Apple Macintosh computers, an
AppleTalk network system, Microsoft Word, and QuarkXPress.
Line art was created with Adobe Illustrator. Proof pages were
printed on Apple LaserWriter printers. Final pages were output
directly to separated film on a Linotronic L300. PostScript™,
the LaserWriter page-description language, was developed by
Adobe Systems Incorporated.

Text type is Times Roman and display type is Narrow
Helvetica. Ornaments and hardware icons are custom symbols
designed for AppleComputer and incorporated into the
AppleIcon Font. Some elements, such as program listings, are
set in Apple Courier, a fixed-width font.


